Cloudflare SSL not Active without www

problem solved when I do purge cache completely in cloudflare dashboard

Hello My Cloudflare SSL is working good if I go but SSL is Not working if I go

What is the problem?

Kindly, may I ask you to look up for and re-check your DNS records at Cloudflare dashboard for your domain to make sure the existing ones are:

  • A www
  • A

Both with the values containing the correct IP address and also both being :orange: cloud (proxied via Cloudflare)?

Or you are using a CNAME type of DNS records?

Maybe you did not added the www record to DNS tab of Cloudflare dashboard?
Which would mean that requests are going to the host/origin server which is using and served over www (web aplication or some other content), but not having an proper SSL certificate (HTTPS)?

Or, you have got some redirection from www to non-www or vice versa, and possible having the issue?

Has the domain recently being added to your Cloudflare account? Maybe the Universal SSL hasn’t been issued yet, if so.

Here are the instructions how to correctly setup an SSL using Cloudflare:

Some ideas what to look for:

The available SSL settings:

More information about Universal SSL:

1 Like

this is my record. is there anything wrong?
i’m new at this sorry about that.

I added my records

Few issues I see so far (OP using GoDaddy):

  1. A mail record shold be :grey: cloud, please click on the :orange: to switch it to :grey: to make sure your e-mail would work as expected, see on the below article why you need to have it like that:
  1. CNAME webdisk.admin and CNAME www.admin would have the issue as described on the below article:
  1. CNAME email and CNAME _domainconnect records should also be :grey: cloud instead as currently being :orange: cloud

  2. Can you post a screenshot of your SSL/TLS -> Overview settings/tab page? Also, using the articles from the previous post, can you re-check what options have you got selected under SSL/TLS -> Edge Certificates?

1 Like

The problem was solved. I do completely purge cache on cloudflare dashboard.

1 Like

I am happy to assist you and glad you figured it out :slight_smile: