Cloudflare SSL CERTs not working

It is changed to Cloudflare CERT and have set SSL/TLS ON and proxy ON for over 24 hours.
Try Flexible and FULL did not work also!
It is still showing old let’s encrypt CERT!
Anything need to set or unset at original server?

For starters, your encryption mode should be Full Strict, otherwise you have no proper encryption in the first place and an insecure site.

Second, what’s the domain?

speech-kids.com
Thanks!

The proxy SSL is working. The question is if your server SSL is working too. What’s your encryption mode on Cloudflare?

Tried Flexible and FULL.
Haven’t tried Full Strict as it is complex!

Well, as mentioned

It appears to be loading just fine. Cloudflare is not a certificate authority, they use partner certificate authorities to issue their SSL certain… Let’s Encrypt is one of those.

Ignore him…. There is nothing you have indicated in your original post that has anything to do with the SSL level between Cloudflare and your origin. He simply believes everyone should run Full Strict all the time every time.

Chris, I am not quite sure about your statement and why you are deliberately misleading the OP and trying to render his site insecure.

There’s a bunch of postings on this subject actually and the OP seemingly has a proper certificate on his server, so by not having Full Strict, he simply downgrades his security.

@alanlovejoey, change your encryption mode to Full Strict and you should be all set. You have a proper certificate on your server and the proxy certificate is also working as mentioned before.

Is the SSL level between his server and Cloudflare’s edge in any way a factor in the OP’s original technical question?

1 Like

That’s not the point. The OP may experience a propagation issue where he is still connecting to the origin.

The site is configured all right and the only thing that’s off here is the security configuration and that’s something the OP ought to know.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.