Cloudflare SSL causing 404

I was migrating my site to a new server and I’ve updated the DNS setting in CloudFlare.

It keep showing error 404 when I visit the website, so I try to change back the DNS setting to the original nameserver ( NameCheap ), and then it works again.

Then I change to CloudFlare nameserver again and disable the universal SSL of CloudFlare and it works, but it’s not when I re-enable it.

Apparently now it’s the old universal SSL causing the problem, I guess it’s redirecting the site to the old server. How do I solve this problem?

I already try remove the website and re-add, but it still not working

Was your site working on HTTPS before you moved it to Cloudflare? If not then that’s the problem and you will need to talk to your host to get your site properly working on HTTPS.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.