CloudFlare & Siteground - DNS & mail server not working

Dear reader,

I’m using a Siteground hosting and they advice Cloudflare’s service to speed up the website. It did. I’m very happy with the results. The only thing that didn’t change for the better was the mail server. My problem now is that I can’t send or receive emails.

I looked into the documentation and community articles around here and I saw more people had the same trouble. Cloudflare does not host email servers, so they need to be directed to the hosting provider. Everything else can be proxied to Cloudflare’s servers.

I’ve read everything I could find on this topic. From Siteground documentation, to Cloudflare documentation, to articles i found in google’s result pages. Nowhere there seems to be a solution that is working for me.

So, I hope someone can help me resolve this issue.

I’ve read these cloudflare articles:
https://dash.cloudflare.com/6c436c5f691bcd07ecbde34691d1bc84/support



You found some good articles. What’s the domain?

Hi sdayman,

The domain is marquant-marketing.nl

You’re using two separate services for incoming mail:

Which app are you using to send and receive email? And which hostname(s) are you connecting to send (SMTP) and receive (IMAP)?

Hi sdayman,

Thanks for trying to help me. The problem is already solved. It was due to a ‘slight misconfiguration’ on Siteground’s site, as they called it.

Siteground Customer service
Unfortunately their slight misconfiguration cost me 9 hours of work over the course of a week and a half. I contacted their customer support four times. The first time an employee told me it was Cloudflare’s fault the mail server didn’t work. So he told me to look into Cloudflare blogs to find out how to solve the problem.

I did and couldn’t find any solutions in the articles I mentioned in my previous posts, so I came back to Siteground. Another employee told me to delete some spam filter mx records. I did. I waited more than 48 hours, for the updated DNS to go in effect. Still nothing happened.

I contacted another employee from siteground, she told me to add the same mx records again that the other guy told me to delete. And to wait 72 hours. So I waited. Still nothing happened.

Then I contacted them again, and another employee put me through to advanced technical help. Within 15 minutes this advanced technical employee answered me and saw it was due to a slight misconfiguration on their side.

Here’s what he wrote me:

Our system checks the MX record of a domain and automatically sets the mail exchanger setting to either local or remote .

In your case, since your domain was previously not using our default MX values, our system has marked the exchanger setting for it to ‘remote’ so I had to manually change it to ‘local’ to resolve the issue. As long as you don’t change the MX records there are no problems expected with the mail service.

After that I updated my linkup with Gmail to send and receive my webmail in my Gmail inbox and now everything works like a charm.

Conclusion:
I would advice anyone with the same kind of problem to ask for help from Sitegrounds advanced technical help. It seemed to me no one from normal support was able to help me. Instead of admitting that they didn’t know, they gave me all kinds of answers that weren’t correct or true.

Within 15 minutes the advanced employee solved my problem.

Hope this helps out anyone else. Good luck!