Cloudflare site crashing


#1

Hello,

Our website has crashed twice today since setting up Cloudflare last Thursday.

The issue seems to lie with the DNS routing or some other part of Cloudflare configuration, as our server is still working fine; we can access the app through another URL and it has not gone down on that URL.

When resolving DNS with Cloudflare, but not using the HTTP proxy, our app crashed 15 minutes ago. It’s back up after pausing Cloudflare service, even though we weren’t using the HTTP proxy in the first place.

There is a page rule set to cache assets that won’t affect our main domain, just one page on a subdomain.

Any ideas as to why this is failing?


#2

What exactly do you mean by crashing?

If I understood you correctly, you said the webserver still responds properly during the “crash” when bypassing Cloudflare and hitting the machine directly, right? If that is the case there is probably some connectivity issue inbetween the problem. Is the site itself on HTTP or HTTPS? Could you post the address?


#3

Thanks for the response, Sandro!

The webserver was responding correctly during the crash when accessed directly, but not when accessed via the domain whose DNS is resolved through Cloudflare.

I.e. the URL that any users of our page access was not working and showing a screen like this:

No idea why this would be resolved by “pausing” cloudflare if the DNS is the only thing being resolved on this domain.


#4

From your screenshot I would assume it is some TLS configuration on your server, which might prevent Cloudflare from sending the request. When you access it directly, do you access it via TLS as well?


#5

Hey Sandro,

Yeah we access it using TLS 1.2 in both cases. From your analysis, the TLS configuration is blocking Cloudflare from serving the page?


#6

Something of that sort. The error message is clear about Cloudflare not being able to establish a TLS connection. Why that is, is something I am afraid I cant tell with the available information.


#7

Thanks for the help, Sandro!

Will post in this thread if I find any additional info.

For context (or if anyone else searches for this info), we are using a low-code framework called bubble to host our application, set up via bubble.is.


#8

This could be an issue with your origin and it’s response time. I ran a number of curls direct to origin for both of your orange clouded records (switching back and forth) and occasionally I would get an extremely slow response. Limited data points and I only used curl, but seemed to happen more on the host name which started with a g… is that the host in question?

Oh tried one more time direct to origin after a slow one and got…

curl -Ik https://gsomething.something.something --resolve gsomething.something.something:443:your.origin.ip.address
curl: (35) Unknown SSL protocol error in connection to gsomehting.somehting.something:443

That was bypassing Cloudflare, so I was able to repro an SSL connection origin direct to origin.


#9

Thanks for the response.

The domain I’m looking into is the naked domain, which doesn’t run through HTTP Proxy (not an orange clouded record).

Feel free to change any of the settings if you think that there is an issue. I can also DM you the URLs to test various domains through without going through Cloudflare, if you’d like.