Cloudflare shows a different Page that is not a Part of Website to some users

Hi Team :wave: ! I have a website here https://stocktalks.tech

  • Intro : I got this domain from get.tech and have a personal Linux Hosting. I just added the DNS Records of my domain in cloudflare then added IP Address of Hosting and simply and installed Wordpress. I did this for someone.

  • Problem: Since the day I hosted the website, Few Persons have told me that they are seeing this specific page on their website. I checked a lot but couldn’t find the solution of it. We predicted that it must have been a cache issue. So tried multiple browsers , But didnt worked. On the same network the users could see the Website in Mobile (A wordpress welcome Page).

  • Temporary Solution: Luckily, We guessed that when we turn on development Mode in Cloudflare the issue got solved and the user could see the correct page. On the exact same URL, Where it is https not http . But then we noticed as soon as Development Mode gets timed out, The User sees the same page.

We contacted domain support but they said that its problem we cloudflare management. Also, We checked hosting, No issue from their side, As I have many sites there none ever faced such issue.

Random Page from unknown Source

  • Situation: I never got the page as shown above which is not a part of Website. But I checked with few people, Among them 40% approx see the same page (Screenshot 1) , 1 of them saw a more different page in some other language, And others saw the correct page, As attached Below (Screenshot 2)

Correct Website Page (Wordpress Page)

From all those we asked, The site worked on mobile but not on PC. And me specifically who manages the cloudflare and hosting, Never saw that page.

We are unable to identify where the issue is, Help would Appreciated as the for the websites maintainer I always need to turn on the Development Mode from Dashboard. I request you, We need the solution to this problem badly :pray:

Cloudflare Settings:

  1. Purge Cache
  2. Turn on Http tp Https Redirect
  3. Check DNS Address
  4. Screenshot of Various Settings from Panel :point_down:

As far as I can see it from my short tests www.stocktalks.tech is configured the wrong way but stocktalks.tech without www is configured the right way.

How can you apply two A entrys for the rootdomain? That normaly shouldnt even be possible.

Also, if you want the www point to the same server as the root domain please CNAME it. As You censored the IPs I can no tell for sure they point to the same IP.
And please delete one of the double entries. Just leave the correct entry.

That indicates you do not have a valid SSL Cert on your origin server. Please correct this first. Set up a valid SSL Cert or install the free one from CloudFlare
(this is just made to work in combination with CloudFlare while proxied)

Also it seems that you have turned off the proxy mode (:orange:) for the root domain in the meantime

EDIT:

your whole domain is not managed by CloudFlare anymore. Your NS are:

ns1.stackdns.com
ns2.stackdns.com
ns3.stackdns.com
ns4.stackdns.com
1 Like

Expired five years ago.

1 Like

Hi ! Thanks for your response on this.

  1. I added two A records for same domain with different IPs because, One has my hosting IP Address and the other is default from get.tech (Their IP Address).

  2. As you said the www must be a CNAME Entry, The IP Address on stocktalks.tech A record 2nd line and A record for www on third line are same, both contains the IP of get.tech DNS which they added.

  3. Response to your EDIT : I changed the namesevers today in morning from Cloudflare to my Hosting Nameservers becuase we were not able to wait for the time. Sorry for this.

  4. As soon as I changed the NS , Website started working and only thing that was broken was SSL Cert. Earlier when the site was buggy, The SSL was working fine for us.

I really feel, the only thing which we messed up was DNS, So for now I am changing back the NS back to Cloudflare, Removing the 2nd Duplicate A record whose IP Starts with 2## and was provided by Domain, I am keeping the IPV4 and IPV6 Address of my hosting which are in the line 1 (A Record) and line 4 (AAAA Record)

Also, For www, I am changing it to CNAME Type and after all this gets updated, I will revert back to the same thread in case any issue occurs.

Really thankful to you, For your kind response and Time. :pray:

EDIT : I also generated a SSL for Origin Server and added the Values in Hosting which installed the External Certificate on it.

No, I did not said that. I recommended it IF it points to the same IPs (IPv4 and IPv6)

I still see (when calling https://stocktalks.tech) the long time ago expired SSL Cert which is not even valid for your domain, but www.stackssl.com:

Sorry Didnt understood this one.

Oh Yes, Just a moment ago I changed the NS and Added the Certificate, I think it takes some time to propogate, Aint It ?

The NS yes, they need some time. But they are already propagated.
See: DNS Checker - DNS Check Propagation Tool

The SSL Cert howevery (on the origin, not CloudFlare settings) should take effect immediately if you have replaced it. But I can not see any change there.

You can go for a free Lets Encrypt SSL Cert, thats no problem. But it should be a valid one.

Oh Yes they have ! BTW Hosting Panel shows a message
Please allow 30 minutes for our load balancers to reconfigure.

Also here a snap of final DNS Records, Please let me know if any changes are required.

The IPV4 and IPV6 Both IPs are provided by the Hosting Service.

Yes I can see the

IPv4: 185.151.XX.153
IPv6: 2a07:78XX::153

But some more things to change to make your setup work:

  1. create WWW CNAME with :orange:
  2. set ALL Mail related domain & subdomains to :grey: as CloudFlare will never proxy Mail traffic and this would break your Mail setup.

How do I setup it back to Proxied then ? Because there is no such option. BTW Mail is working properly as I checked last before changing NS

EDIT : However, You can now check the SSL, It has been applied and Updated.

Click “Edit

And then click on the orange cloud (:orange:) so it changes to grey cloud (:grey:)

Thats the problem. If you check after the NS change it will not work anymore because CloudFlare will not proxy Mailtraffic. please switch it to :grey:

Sorry have to correct, now the SSL Cert from CloudFlare is getting shown on the prigin. Very good!
Now turn on “Full (Strict)

Nope still can’t Change

How do I do that ? :thinking:

Here is the Screenshot of SSL Certificate from my Side.

image

Yep, this works now.

I was talking about the Mail-Related CNAMES/Domain Entries which you marked here:


Not the MX Entries :slight_smile:

Oh Yes, I switched SSL to Full (Strict)

And here is one message from DNS from Top :slight_smile:

And here is the Screenshot where I changed the MX records to DNS Only from Proxied

I hope everything is fine now ? :smiley:

Not yet. You still have not done this:

Let this CNAME (WWW) point to “@” (which stands for your rootdomain)

EDIT UPDATE : I just checked , The website now shows this, When I changed it to Full (Strict)

Can you run (in CMD or PowerShell) these commands and give me the return value for each?

  1. nslookup stocktalks.tech (local/default DNS resolver)
  2. nslookup stocktalks.tech 1.1.1.1 (CloudFlare DNS resolver)
  3. nslookup stocktalks.tech 8.8.8.8 (Google DNS resolver)

Really Sorry, It is becoming like Spoon Feeding. I am unable to focus., Sorry for the inconvenience caused to you, Here I did it :point_down:

UPDATE : On alternate reloads I see this page and the correct page

Here is what you requested above:

Very good, [email protected] is now also pointing to the very same IPs.

That looks good aswell.

I dont see this page. Please test it with your mobile phone with mobile internet.
For me both domains work now:

  1. https://stocktalks.tech
  2. https://www.stocktalks.tech (redirects to https://stocktalks.tech)