CloudFlare setup Help

Hello, I recently started using cloudflare.

I change the name servers to the ones that cloudflare provided me. (I use godaddy)

But how do I use my hoster now? I run the website via my own server I have. I’ve tried to change the ips’ on cloudflare for the records but nothing happens and my website stays the same.

Website: https://gkey.xyz/

That site is only using Cloudflare DNS (not Proxied), and shows an IP address ending in 121. And it’s not loading.

Yes, the ip ending in 121 is the server that I’m using. What should I try and do about it?

That’s completely up to you. It’s not working right now. Your website needs to work with HTTPS before you add it to Cloudflare.

How can I make it work with https? Sorry, I’m new to this.

I suggest you visit sites like serverfault.com and stackoverflow.com for sysadmin help.

Thank you for the help, i will do that.

1 Like

Sorry to bother you, but cloudflare gives free ssl. Wouldn’t that be https?

Cloudflare can provide an SSL certificate for your server so it can run HTTPS when proxied by Cloudflare:

Ah, ok. I enabled the proxy option in the dns settings @sdayman

That is my server ip which is outputting the website

Hello, I already made a post like this but I have a question similar but not exact.

I changed my nameservers on godaddy to the ones that cloudflare provided to me.

I have a server running on a second router the ip is: http://71.112.184.121/

I have gone in cloudflare and changed the A records to this ip and yet it is still not changing to what is being brodcasted.

The website is: https://gkey.xyz/

Hello, when i go to my website, it gives me error 522

I have my host running and all records set to the ip which the website is hosted on

And yes, its a host error.

Can somebody help?

I use a dedicated router and if I go to the ip it shows the websites but, but on gkey.xyz its not

Please don’t put your broken server on Cloudflare and expect us to help you fix it. I already told you not to put it on Cloudflare until it’s functional, and that includes HTTPS.

2 Likes

Well, it wasn’t boken beforehand when I never used cloudflare. I asked how to rout my server through cloudflare.

Https was working amazingly beforehand.

@sdayman Hello, I’m extremely sorry about that. I took in to mind what you said and I was able to fix it. Sorry for the hassle but thanks

1 Like