Cloudflare settings for prestashop?

as soon as both cloud-flares DNS and HTTP Proxy are enabled
the site goes down

if I had SSL “Flexible” on
I would get too many redirects
and if I go “Full (strict)” on
I get 500 Server Error

prestashop 1.7 and I have my own SSL certificate’s and SSL has been enabled for all pages

also when the proxy is enabled I can not access my other ports via DNS and connection to SQL database is lost

I am meant to be adding them via SRV ?
Service “_SQL”
Name " DNS name " ?
Port “3306”
Target "DNS name "? )

I more or less just want Cloudflare for DNS and caching for offline access and hosting website from home

With Flexible SSL read here for redirection loop. Anyway using Flexible SSL is not recommended and you already have a SSL installed on your sever, let’s go with Full SSL.

You get a 500 internal server error which means something is definitely wrong with your server and you need to check server logs but from the second part of your question I guess that is a SQL connection error. You cannot put your SQL database behind Cloudflare (CF). CF just proxies http(s). Same question answered here.

1 Like

Thanks for reply changed SQL to point to IP address instead of DomainName,
but as soon as Cloudflare DNS+Proxy is enabled it goes back to 500 errors

would I be better removing SSL from the server and just using Cloudflare , but I am pretty sure when I tried that I had constant redirect loops

A DomainName points to IP TTL Auto DNS+Proxy
CNAME www is alias of Domain Name Auto DNS+Proxy

I just created a fresh account without any SSL on the backend it that seems to work fine

but if I try and activate SSL through prestashop it will not work and this is with Cloudflare set full SSL ?

This site can’t be reached ***** refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

edit
gave up with prestashop used opencart
and no issues yet
( apart from not having AUD currency or support for live shipping calculations with my available couriers)

Then you need to check server logs for 500 error. Something goes wrong when Cloudflare connects to your server via 443 (I guessed SQL connectivity but seems a wrong guess).

No. Full SSL is recommended and you need to solve the internal server error (http 500).

Your settings are correct.

It seems the problem root is the way Prestashop installs SSL. SSL is something related to your web-server (Apache, Nginx…) so installing it via Prestashop seems odd. Maybe there is a option in Prestashop to use SSL not installing it, then you need to install it yourself.

As error message says this happens mostly when there is a firewall or proxy issue.

Tip: From your Clodflare panle disable proxy for your both entries (gray cloud instead of orange) and troubleshoot your website. This way Cloudflare just resolves your DNS and any error is not related to Cloudflare. WHen your website worked over https, enable proxying (orange cloud) and in case of any error, that’s something related to CF.

This topic was automatically closed after 30 days. New replies are no longer allowed.