Cloudflare serving old version of website

Complete this information in order to ask your question.

Have you searched for an answer?

Please share your search results url:
I’ve been through multiple Cloudflare community tickets and tried to apply their answers to my case, nothing worked so far.

When you tested your domain using the [Cloudflare Diagnostic Center], what were the results?

Describe the issue you are having:
Cloudflare is serving an old version of my website

What error message or number are you receiving?

The error message is due to the fact i’m getting an old version.

What steps have you taken to resolve the issue?

  1. I’ve tried setting the Browser Cache TTL to Respect Existing Header
  2. I’ve tried Purging all the cache from the Cloudflare interface multiple times
  3. I’ve tried clearing my own browser cache multiple time and also accessing the website in Incognito mode, different browsers, different devices and through TOR. The only one that was consistent in serving the new version of my website was TOR. The other ones sometimes either served the new version or the old version
  4. I’ve tried pausing Cloudflare from the interface and everything works fine afterwards

What is the domain name?
domain name is walkofwater dot org

Was the site working with SSL prior to adding it to Cloudflare?

I believe SSL is provided by firebase where the website is hosted

What are the steps to reproduce the error:

  1. Accessing the url you can see either that the javascript doesn’t load properly or the images don’t load at all. Sometimes the right version is served and everything works as expected.
  2. This is due to the fact an old version of my website is served and it’s trying to access resources from a server which is not online anymore. The issues with javascript not loading properly are likely due to the Service Workers running in the background trying to load resources with a different hash.

Have you tried from another browser and/or incognito mode?
Please attach a screenshot of the error:

These are the 2 different error statuses one might receive.

Hello @apophis.paul I’ve replied to your ticket, where we will continue support. Looks like the error was coming from the origin server.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.