Cloudflare seems to slow my website by 1000%, what is causing this?


#1

Hello fellow cloudflare users.
Before Installing SSL and Cloudflare my page speeds where excellent.

Pingdom, GTMetrics both gave it Full A’s with a nearly 100% score.
Site load speed was never higher than 1.3 seconds and the page size was below 500 kb.

Now I installed SSL through the free Origin SSL certificate that Cloudflare provides and enabled Cloudflare on my website and my scores and site loading speeds went… downhill a lot.

These are my scores now:

GTMetrix: gtmetrix.com/reports/getleanstrength.com/vgxFdpN4
Page speed score: D 68
Yslow score: C 78
Fully load time: 17.8 seconds
Total page size 1.80 MB
Requests: 62

Webpage test score: https://www.webpagetest.org/result/180619_WF_50414deef253ff8ce0fec9f6c566a081/
Fully load time: 10.86 seconds

Pingdom:(Link removed due to a limitation of 2 links per post)
Score: C 78
Load time 6.81 Seconds

Now, these load times vary, but the scores and the loading times are a LOT worse than ever before, while the only thing I changed was enabling SSL, and Cloudflare.

—————————————————————————————-
Here are my Cloudflare settings:
SSL Certificate: Origin (free certificate from Cloudflare)
SSL Settings: Full (Strict)
Page

These are the steps I took:

  1. Generate Origin SSL from Cloudflare
  2. Add it to the SSL certificates in Cpanel
  3. Enable the Real Simple SSL Addon and enable it
  4. Change DNS to Cloudflare DNS
  5. Enable Cloudflare Plugin in WordPress and set it up with the APIs and whatever not.
  6. Enable Cloudflare in my cache plugin.
  7. Purge cache (both through my website plugins and in cloudflare)

Cloudflare settings: ( I changed the direct links and replaced it with mysite due to the link limitation in this post)
Cloudflare Crypto settings:
Full(Strict),
Always use HTTPS, (on)
Opportunistic Encryption, (on)
Automatic HTTPS Rewrites(on)
Cloudflare speed settings:
Auto Minify (off)
Enable Accelerated Mobile Links (off)
Brotli (on)
Rocket Loader (off)
Page Rules:
mysite/ Always use HTTPS
mysite/preview=true
Browser integrity check (on)
Browser cache TTL 30 minutes
Always online: off
Security level: high
Cache level: Bypass
Disable apps
Disable Performance
/wp-admin*
Browser integrity check (on)
Browser cache TTL 30 minutes
Always online: off
Security level: high
Cache level: Bypass
Disable apps
Disable Performance

Cloudflare scrape shield options:
Email Address Obfuscation (on)
Server-side Excludes (on)
Hotlink Protection (on)

I put the above settings from a guide I read on the internet for best settings of WP Fastest Cache with Cloudflare.
————————————————————————–
My caching plugin is WP Fastest Cache
————————————————————————–

I also wonder how it comes that by enabling ssl + Cloudflare that the page size went from 500 kb to 1.8 MB.

Does anyone know what I do wrong? What settings should I change to get decent or back to good speeds?


#2

there are 2 issues causing it
first turn on really simple ssl on wordpress- to prevent unneccessary redirect
two- use scaled images- use jetpack photon or manually scale images


#3

Hi!

You have multiple issues there… first of all enable caching, HTTP/2, reduce the redirects (you are doing 3 going from the root to the www subdomain with HTTPS, you can combine them in a page rule on Cloudflare). You are most likely having some sort of high first page load, probably caused by your server.


#4

Hey thank you,

I have the addon Really Simple SSL enabled and I am using the HTTP Redirect Option.

Thank you, I have Caching enabled through the plugin “WP Fastest Cache” along with the cloudflare “Standard” Caching.

HTTP2 is on In cloudflare.

Currently I just use the really Simple SSL plugin to handle the redirects.
So should I combine them through a pagerule in Cloudflare and remove the Redirect in the plugin?
(What settings should I use for the pagerule to function properly?)


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.