Cloudflare returns 502 for 302 response

We have our backend running behind Cloudflare. Somehow one of your endpoint which returns 302 redirect is displayed as 502 when running behind Cloudflare. Why is this? It works perfectly when there is no Cloudflare in front

302 page location header value is:
https://test_1524.dev.jetadmin.io/oauth_response#msg=%7B%22value%22%3A+%2200DHu000002ifoN%21ARAAQG_lnmMbuFJqAjwmvRIv_Z_Vt575KDhZEtqPdKuSS2pr7gOU_1WGfokBXy6yuChRKA_rXc0DrR604ywPaVi4LZEr_TsO%22%2C+%22params%22%3A+%7B%22KEY%22%3A+%223MVG9VTfpJmxg1ygffL8Iqg6yWEql0fqBxKuSFU1Di4t.VHU.O0kmFUr2sgtNnRuuMRDJi6OVB6HjoMAQcq2N%22%2C+%22SECRET%22%3A+%222C521A12C4657BC1D8B86B98C649E1711D9BA66E3DFFD73C0D1C1C1B3B48766A%22%2C+%22SCOPE%22%3A+%5B%22api%22%5D%2C+%22SCOPE_SEPARATOR%22%3A+%22+%22%2C+%22backend%22%3A+%22social_core.backends.salesforce.SalesforceOAuth2%22%2C+%22auth_time%22%3A+1703880811%2C+%22id%22%3A+%22https%3A%2F%2Flogin.salesforce.com%2Fid%2F00DHu000002ifoNMAQ%2F005Hu00000Q1NOkIAN%22%2C+%22instance_url%22%3A+%22https%3A%2F%2Fefficiency-inspiration-9633.my.salesforce.com%22%2C+%22issued_at%22%3A+%221703880809705%22%2C+%22signature%22%3A+%22WXUlg0KhhjhSTxbdTizMnaG5PWGB3OPKy8kcQkttBH4%3D%22%2C+%22refresh_token%22%3A+null%2C+%22access_token%22%3A+%2200DHu000002ifoN%21ARAAQG_lnmMbuFJqAjwmvRIv_Z_Vt575KDhZEtqPdKuSS2pr7gOU_1WGfokBXy6yuChRKA_rXc0DrR604ywPaVi4LZEr_TsO%22%2C+%22token_type%22%3A+%22Bearer%22%2C+%22token_updated%22%3A+1703880811%7D%7D

Switching Security → Settings → Security Level from Medium to Low solved the issue. Is there any reason for it?

Changing the security level suggests this was a challenge.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.