Cloudflare refuse to delete index.html from Cache

I just used an index.html to temporary “disable” my website so I can work on it. But now I try to get rif of the index.html so the index.php (and Joomla with it) works again.

However: Cloudflare refuse to delete the index.html from its cache.

What I tried so far:

  • Purge everything
  • Turn on Developer Mode
  • Turn of Cloudflare for a while (it stays active if I go to the overview…)
  • Remove the index.html file anyways
  • Remove my website from Cloudflare and add it again. Well… still cached.
  • Waited for another hour
  • Changed Browser Cahce TTL to 2 minutes
  • Used a PageRule to Bypass the Cache Level of the full website
  • Used 4 different browsers as well as my mobile to ensure it’s not my browser cache
  • Used a proxy to ensure it’s not something else

What makes you think Cloudflare is still caching it?

Well I dont know what else should be caching.

My browser is in private mode already and if I directly call the index.html file within the domain, it tells me 404. So where’s the content coming from if not Cloudflare, which is supposed to cache.

And it kinda looks like it is indeed a Cloudflare bug:

This guy seem to had the same problem in the not-to-far-past…

What are the response headers of the index when you request it in the browser?

Problem could be solved by the Cloudflare Support: Reason was the CDN of the ad network Ezoic, which somehoe came in. But since I moved away from Ezoic like one day before, this still interfered somehow.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.