CloudFlare redirects to unknown domain?

Is it possible that Cloudflare (CF) could be caching a domain that might have been set up previously by a different third party?

We’re hosting a WordPress (WP) site that wasn’t developed by us. We want to use CF proxies but when ever this is enabled the browser redirects to 3dcartstores.com which isn’t anything to do with the site. I thought at first that it may be a WP plugin and/or theme that is redirecting, but I’ve done a text search through all files and nothing is returned. I thought it may also be from the database and after a full text scan it’s found nothing either. So I tested by uploading a text file to the server to bypass WP altogether.

If I access the URL without www i.e. example.com/test.php it redirects to 3dcartstores.com, if I access it with www i.e. www.example.com/test.php I’m able to see the contents of the text file.

So I know it’s not the WP installation. I can only think that the domain was added by a third party previously and CF is caching the redirect or rule that might have been set up previously. I can’t contact CF because I only have a free account but this is their issue. Any ideas???

Thank you!

Did your site originally work fine on HTTPS?

What’s the domain?

@pete.batin, the thread has been reactivated again

@sandro, thank you for reactivation.

Yes the site worked absolutely fine via HTTPS. As soon as I switch on CF Proxy it redirects to an unknown domain, if I switch off the proxy it works fine again. These are the Response Headers I’m getting from CF without www

  1. age: 1815
  2. alt-svc: h3=“:443”; ma=86400, h3-29=“:443”; ma=86400
  3. cf-cache-status: HIT
  4. cf-ray: 771cda5729a47779-LHR
  5. content-type: text/html; charset=UTF-8
  6. date: Tue, 29 Nov 2022 16:52:17 GMT
  7. location: https://www.3dcartstores.com
  8. server: Cloudflare
  9. vary: Accept-Encoding
  10. x-powered-by

With www. I get the following Response Headers and the text file displays.

HTTP/2 200 OK
date: Tue, 29 Nov 2022 17:05:23 GMT
content-type: text/html; charset=UTF-8
cache-control: max-age=691200
expires: 30
vary: Accept-Encoding
x-ua-compatible: IE=Edge
cf-cache-status: DYNAMIC
report-to: {“endpoints”:[{“url”:“https:\/\/a.nel.cloudflare.com\/report\/v3?s=Rk9SJVp95mWuETVNgu8WFDOa1fkGNRVCHGZa9ywaQKD6J91k68G5l5r%2BmCQX6q6U%2B93DXKt4PbJWfwk47LoWVsO2ZPkNCZ5jVnGh4JsqsoT189e0XI45OxBEQ2mqCsGMYonkszaXQJHgmhHC8Q%3D%3D”}],“group”:“cf-nel”,“max_age”:604800}
nel: {“success_fraction”:0,“report_to”:“cf-nel”,“max_age”:604800}
server: Cloudflare
cf-ray: 771ced86eae37453-LHR
content-encoding: br
alt-svc: h3=“:443”; ma=86400, h3-29=“:443”; ma=86400
X-Firefox-Spdy: h2

Again 3dcartstores.com has absolutely nothing to do with us.

The domain is hammond-drysuits.co.uk

In that case you will be most likely running into this issue

1 Like

Thanks @sandro, I think that’s most likely the issue. I’ve tried adding DNS CNAME records as the tool suggests to regain ownership but it says the record already exists. I think somehow that the DNS setup for this domain still exists in someone elses CF account. The interesting thing is that we have been managing this domain for some months now, we control the DNS and the old CF records should have well expired by now.

I’m now reverting the DNS back to our original DNS server and I should then be able to setup the CNAME records.

There aren’t really any entries to expire, the issue is your naked domain is still managed by the Cloudflare settings of that other provider. And mentioned service would allow you to take back control.

You will first have to drop the entry for the naked domain before you can configure a new CNAME entry.

That’s the thing, we have had control of this domain (and hosting) for 6 months now and using our own DNS (not CF).

CF deletes domains after 7 days, these previous rules/settings from the 2nd to last provider (which was prior to 2022) so I can’t understand why they’ve been allowed to survive.

You are mixing two things here :slight_smile: Cloudflare does drop traditional domain setups if the nameservers are not configured, but here we are talking about a different setup.

But your naked domain appears to work fine now.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.