Cloudflare redirects port 2095 to 80

On my webserver I have apache running on port 80, sending index.html, so upon visiting the page you get index.html from apache. I also want a backend API for the website that is proxied though CF, so looking at the ports that CF allows for, I chose port 2095 for this API. I wrote the API and bound it to that port, and upon visiting it on my IP, it works fine. The issue is when you visit it though the domain (domain.com:2095) it redirects to “domain.com” and pretends the port was never there.

Any ideas on how to fix this?

Are you still having issues @user17373?

Port 2095 does not proxy https traffic, maybe turn off always use ssl and and if you get different results? :person_shrugging:

3 Likes

the always use https rule was the issue, my API uses http and Cloudflare was enforcing use of https, causing it to not work. Thanks for the help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.