Cloudflare redirects always to HTTP

Hello Guys,

I habe a funny effect – I always get redirected to HTTP, tried already some changes also a custom rule in cloudflare but if I do this, I get of course the error “Too Many Redirects”.

image

Certfificate is valid – in cloudflare everything looks good. To make it even worse, it worked already - I have changed nothing. Just by accident I have seen today that my browser started to show “unsecure” – I was wondering that my bookmark was wrong. But no it was HTTPS // and it worked now for months.

Settings are normal:

  • “Your SSL/TLS encryption mode is Full”
  • “Universal SSL Cert was recreated valid until 2021-06-19 (Managed).”
  • Always Use HTTPS is off of course as otherwise I get into the redirect loop.

So far all looks good.

Thanks

Paul

If it’s not a Page Rule at Cloudflare, then something at your server is redirecting this.

If it’s a server issue, then I suggest you “Pause Cloudflare on Site” from the overview page and wait five minutes for it to take effect. Then make sure your site is working correctly with HTTPS.

1 Like

You are right it was the server-side and not Cloudflare as it seems. Thanks for the support.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.