Cloudflare Proxy retuning a 302 redirect to same domain

I’ve setup multiple domains on CF, and all point to the same IP, my servers IP. All the A records are set to proxy, and they work. Except for one, myhousefromabove.co.uk. It returns a 302 status with location https://myhousefromabove.co.uk/, which returns a 302 to https://myhousefromabove.co.uk/, repeat.

The setup is no different to any of my other domains. Not sure why this one isn’t working. If I disable the proxy, then it serves up the correct website from my IP. Any ideas on what i’m missing?

Thank you in advanced

Is your TLS/SSL setting Full (Strict)?

3 Likes

Thanks for the reply. The TLS is set to Flexible, this is the same as my other sites.

Apart from the big issues with having Flexible, that’s also causing the issue most likely. Your server is redirecting to HTTPS and Cloudflare due to the setting is fetching always on HTTP.

2 Likes

Thanks for both of your replies!

I lied before, unintentionally! It was set to Flexible, but all of my other domains are “Full”. I did not check, because… Well I was so sure I had already checked. Lesson in humility there. I changed it to Full, and it worked instantly. Thank you both for getting me to check a setting I thought was right twice

1 Like

Given you have a certificate installed, I would recommend making sure it’s a valid one, going up to the Full Strict option. If you want a valid certificate you can use the Cloudflare Origin Certs, which are free and Cloudflare trusted. They aren’t trusted by users, though.

1 Like

It seams to be showing as valid when I visit https://myhousefromabove.co.uk/ now, does it not for you?

I meant on the server, the website URL would show the Cloudflare-issued certificate, which is not what the SSL/TLS setting changes.

I’m not 100% sure I follow. Users visiting my website see the Cloudflare SSL cert, and that is trusted by their machine. Cloudflare then connect to my server and trust my cert (Which is a Lets Encrypt certificate), and that’s transparent to the user, as the connection is proxied.

With the Full mode Cloudflare doesn’t care if it’s valid or not, it could be self-signed or for another domain. If you have a valid cert on the server set it to Full (Strict) so that it’s actually validated.

And if you do not, make sure you configure a valid certificate.

He did mention a Let’s Encrypt certificate.

Could also be invalid :wink:

But I just wanted to follow-up on your if.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.