[Cloudflare Proxy] 503 Service Temporarily Available only on POST Requests

Hi, I’m having this issue for months. It started suddenly, now it stuck. That’s the reason I don’t use Cloudflare Proxy anymore and I want to solve it to re-use again

Context;
I’ve installed Origin Server cert to my server successfully. I’m using SSL on full mode.
GET requests works perfectly.
I don’t have any WAF/Firewall/Rate Limiting Rule. To be sure, I created and disabled, removed.
I have Page Rules, but not on these routes.
It’s not server related, request doesn’t even reach to my server.

This is the endpoint I’m trying with. It fails on every POST request, endpoint doesn’t matter actually.
POST https://api.artlabs.ai/admin/login

This is how it fails

This is response headers

This is cdn-cgi/trace

fl=270f4
h=api.artlabs.ai
ip=24.133.172.61
ts=1647510414.611
visit_scheme=https
uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.109 Safari/537.36
colo=MXP
http=http/2
loc=TR
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

Now, Cloudflare Proxy is disabled, because we have a running business. So you can’t reproduce it. I just need some ideas to try. Also, 5XX Troubleshooting page suggests to create ticket but it’s practically impossible, by design. I’m on free plan but also it’s not possible to create tickets in Pro plan too. So, how much should I pay to get support?

Thanks

Is this what you are referring to?

Have you tried these steps?

That is definitely not the case, Pro customers have ticketed email support available through the dashboard. Login & go to https://dash.cloudflare.com/?account=support and select get more help.

If you are a Free customer then you will need to post the issue here as you have done, make sure you post all the information from the list above. If the community cann’t help address it, we can escalate it to Support where needed.

Yes.

And yes.

The problem seems to be happening when sending Content-Length header. I’ve checked my server’s CORS configuration, it seems fine.


 cors: {
        enabled: true,
        headers: [
          'Accept',
          'Accept-Encoding',
          'Accept-Language',
          'Origin',
          'Content-Type',
          'Content-Length',
          'Content-Language',
          'Cache-Control',
          'Authorization',
          'User-Agent',
          'Referer',
          'X-Requested-With',
          'X-Frame-Options',
          'X-API-Token',
          'x-api-key',
        ],
        credentials: true,
        origin: '*',
      },

Created a proxied DNS https://api-debug.artlabs.ai

Also sending ticket with Pro plan.

Also this is definitely the case. I’ve upgraded and tried to send a ticket but this is what I got;

Did you select the domain on the upgraded plan? That should not be the case.

Can you post the ticket number here.

Okay, you were right. I’ve been forwarded to an Agent.

Any ideas about why Content-Length header may breaking it?

I’m not sure, I’ve seen similar issues where it has been due to having multiple Content-Length headers but doesn’t look like that’s the case here.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.