Cloudflare Premium via Bluehost causing DNS Resolution 1001


Bluehost (my host provider) is trying to set up Cloudflare premium up I bought via their marketplace within my Bluehost cPanel dashboard. Prior to this, I managed Cloudflare premium directly via Coludflare, here, and I simply pointed the nameservers which worked fine (I switched to save money).

Unfortunately, since the DNS re-initiation on Friday June 2nd, I have lost full access to my WordPress dashboard, and associated website, for the past 5 days. It cannot be accessed by anybody. The WordPress website files are not corrupt etc… it appears to be a DNS resolution failure error - 1001 Error.

The website associated with my domain is permanently down as a result, however emails associated with the domain work, which point to a dedicated Bluehost IP address. Bluehost’s escalated support are currently failing miserably to find a solution to get Cloudflare premium working for my domain and associated access restored to my WordPress dashboard/website. This is meant to be a standard feature that works for many other users who have purchased it through their cPanel dashboard on a subscription.

The catch is Bluehost manages and sets up Cloudflare Premium, not me anymore, so I cannot simply point my nameservers to Cloudflare’s servers and mess around over here with my Cloudflare Premium user dashboard account settings. Bluehost set up and manage Cloudflare Premium on my behalf so I do not get a Cloudflare dashboard any longer to customize settings etc. I am beginning to wonder if this switch was a fatal mistake. I am new to all web design and this is my first website. I am competent with Python development so I do have relatable experience to understand some of the jargon and backend workflows.

I am wondering if my old Cloudflare Premium configuration that was previously setup here may still somehow be conflicting, preventing the DNS from resolving under the new account in Bluehost’s cPanel? I did unlink my domain/website here prior to the activation of Cloudflare Premium in Bluerhost’s cPanel last Friday. Does anybody have experience with this sort of issue and how to resolve it?

Not that I can do much because Bluehost probably has to resolve this themselves for me? Sadly, I read a lot of reviews that Bluehost does not have the experience required for these type of problems, so I am losing hope at a solution. I have had zero access to my website for 5 days (and WordPress admin dashboard) which is far too long and is impacting my life.

I suggested to them do download my website files and create a whole new cPanel for me starting from scratch given all the normal stuff is not working, they don’t like that idea… even the IT crows say turning it off an don again is often the way in the worst cases. Bluehost seem to think that re-propagating the DNS a few more times will magically solve it… I am less than convinced, especially because more and more green ticks shown on change into big fat crosses in increasing numbers each time. My domain is, for anybody who wants to see the error.


Your domain does currently have an invalid dnssec configuration that needs to be fixed before anything else.


I appreciate this insight. The domain was working last week, and now it isn’t… so I have no clue what Bluehost messed up. It all broke immediately after their support agent failed to implement a Jetpack premium installation which I purchased through my Bluehost cPanel. All they keep doing is trying to re-propagate the DNS 10000000 times… which… based on what you are saying, and what I believe, wont move the issue forward.

Whatever you mention sounds like may help to move the issue forward so I will mention it to them. If its something I can do via via the Bluehost cPanel, I will try to learn it and sort it myself because my confidence is near zero for Bluehost atm for fixing this this calendar year. 5 days is to long already for an outage that wasn’t a result of my own actions, but theirs. Cheers!

Your dnssec would have become invalid the second you switched from Cloudflare to Bluehost nameservers.

This means your domain will not work for the majority of people.

To fix it, you need to get the correct dnssec value from bluehost and enter it at your domain registrar, or disable dnssec at your registrar.


Its crazy, because my domain registrar is Bluehost. I will them to do this. Thanks!


Bluehost is still having zero success. I still cannot access my site for 6 days now. It is messing up my life. I am wondering if the situation in this post is the issue… Cloudflare is ‘double activated’… I originally pointed to Bluehost when I got my domain from them, then I pointed to Cloudflare, managing it here, then I pointed back to Bluehost and back to Cloudflare when I switched to their in-house Cloudflare management services. My name servers are currently pointed back to Bluehost to debug and the DNS still wont resolve. I am not sure what do to, I am seriously concerned I will not get access back and am unsure who to reach out to for support because its clear as day Bluehost don’t know how to resolve this issue… so I need to find reliable external support to help me handle Bluehost and teach them how to fix the problem:

The DNSSEC configuration is still invalid. Maybe it would be easier for Bluehost to disable it on your domain if they don’t know how to correctly set it up?
Until then, your domain will not resolve, that is the purpose of DNSSEC.


I have tried telling them this. I think I need to find an agency to tell them to do this at this point because they are not listening to me.

You could also try to disable it yourself:

1 Like

Thanks, I will see what I can do because I have nothing to lose at this point.

I think I just need to turn this off if I understand the basic 4 steps correctly (which are a little outdated).

amazing… turning that setting off at least gives me access back to the site I am making. I am gunna call them to raise some ■■■■ tomorrow.

1 Like

Still major issues and access has gone again. I am going to try and repoint my nameservers BACK to Cloudflare and manage it al myself again here to see if that fixes the issues. Its almost as though they broke something else. I told them what I did to fix it (and now it is broken again after they did something else and have blocked me from editing my A records and deleting cloudflare premium from my cPanel. I think I am going to migrate away from Bluehost to get the problems solved elsewhere because this seems like one huge troll. I will probably claim back money and launch a formal complaint. I am reading good stuff about Cloudways on all the ‘Do not go with Bluehost blogs’ out there on the internet.

DNSSEC is still active and invalid.

Until you change that, you don’t really need to try anything else. If Bluehost doesn’t have any options in the menu to change that and the support also cannot disable DNSSEC, you will have to move the domain to another company.

An invalid DNSSEC configurations basically tells DNS servers that they should not respond when your domain is queried, so nothing will work.

In this post on the Cloudflare forums, someone else had the same problem, but it appears there is a menu to change the DNSSEC values, someone else had the values changed by the support.


I am on their phone to their front team now. I am telling them in a very strong northern English accent this information. I typed similar to them 3 days ago and told them less sternly. Hopefully their back team disable or set up the4 DNSSEC. I will keep you posted.

A final update - I have charged back to Bluehost and I will migrate away from them to get a new registrar (probably Cloudflare) and new server host (probably Cloudways - Digital Ocean). Bluehost were unable to resolve the issue and I got further than they did towards a solution = I cannot trust them as a registrar, nor a host. Unfortunately, I cannot recommend Bluehost as a reliable partner because once a technical issue crops up, which falls under their responsibility to fix, you cannot expect a solution. What a terrible experience, this sort of downtime is a potential life runner for some businesses, and has negativity impacted my life.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.