Cloudflare plugin (version 7.0.1) uses cPanel API 1

We noticed an alert from cPanel about the fact that Cloudflare plugin uses cPanel API 1 - https://dropmefiles.com/R3SKK. Also, there are a lot of errors in /usr/local/cpanel/logs/error_log [1].

Do you plan to switch the plugin from cPanel API 1 to cPanel API 2 and if so, when?

[1]
[2020-03-16 13:10:48 +0100] info [cpanel] Filemanager::get_file_content => The file <80><9C>/home/XXXXX/.cpanel/datastore/cloudflare_data.yaml
<80><9D> does not exist for the account.
[Cloudflare] ERROR: [CPANEL UAPI] Array
(
[type] => response
[body] => Array
(
[cpanelresult] => Array
(
[module] => Fileman
[result] => Array
(
[warnings] =>
[status] => 0
[data] =>
[errors] => Array
(
[0] => The file <80><9C>/home/XXXXX/.cpanel/datastore/cloudflare_data.yaml<80><9D> does not exist for the account.
)

                        [messages] =>
                        [metadata] => Array
                            (
                            )

                    )

                [func] => get_file_content
                [apiversion] => 3
            )

    )

)

I am not sure you’ll get a fundamentally more profound response here than what you already got over at https://github.com/cloudflare/Cloudflare-CPanel/issues/185

Cloudflare does not appear to be overly active when it comes to that code base and I wouldnt count on an update all that soon.

Have you tried contacting them at cpanel AT cloudflare DOT com? The people at https://github.com/cloudflare/Cloudflare-CPanel/graphs/contributors might also know more.