Cloudflare Plugin (APO Issue) | How to Perform A Complete Plugin Uninstall?

We are having some issues with Cloudflare’s plugin and our Cloudflare Dashboard:

  1. The plugin’s APO settings section and our Cloudflare dashboard detected a staging site we created, so we deleted both our staging site and the plugin, then reinstalled the plugin. Unfortunately, the staging site still appears in the APO settings section of the plugin. Issue remains after all cache has been cleared. So, does anybody know how can we perform a complete (clean) uninstall of the plugin – including the deletion of all CF cache and CF database records?

  2. The plugin’s APO settings section continues to display the message: cf-edge-cache response header is missing! although our Cloudflare’s Dashboard (Speed > Optimization > APO) detected our website and the plugin. It also detected our staging site. Ugh. So, how can we clear the Cloudflare Dashboard (Speed > Optimization > APO) to delete the non-existent staging site? Also, how can we fix the plugin’s message?

Team Cloudflare appears to have abandoned its plugin. Hopefully, that’s not the case.

Help appreciated. Thank you!

Try the API:
https://api.cloudflare.com/#zone-settings-change-automatic-platform-optimization-for-wordpress-settings

Hi @sdayman,

Thanks for the reply.

Can you expand more on your proposed solution? Does it address our issues? What steps do we need to follow to fix them?

Cheers!

This is NEVER the right next step.

1 Like

I agree! Do you have any other suggestions for a complete uninstall/reinstall of Cloudflare’s plugin and a complete reset of Cloudflare APO?

Update:

Issue 1 solved as follows: (a) Deleted the Cloudflare plugin, (b) Deactivated APO within Cloudflare, (c) Deleted a DNS record we had with a CNAME Name = *, (d) Flushed all cache, (e) Reinstalled the Cloudflare plugin, and (f) Reactivated APO within Cloudflare. APO is no longer detecting any of our staging sites.

Issue 2 not yet solved. That is, after performing the above steps for Issue 1, we’re still seeing the persistent plugin message: “cf-edge-cache response header is missing! Please clear any server cache used via other plugins.

Cheers!

1 Like

Have you checked for the presence of that header? I use the following:

  1. curl -svo /dev/null https://example.com
  2. curl -svo /dev/null https://example.com --connect-to ::ORIGIN_IP

I often do #2 on the local server, and sometimes even use 127.0.0.1 for ORIGIN_IP if I run the curl command on the origin server.

Hey @sdayman,

Thanks for that!

Yes, tried your command (No. 2). Unfortunately, the results do not show the expected “cf-edge-cache” header response.

Details: Screenshot by Lightshot

The above also matches the results obtained when using the online header tester: https://httpstatus.io

Details: Screenshot by Lightshot

So, in short, it appears there’s a connectivity issue or bug with Cloudflare’s plugin and/or APO’s code (there are not “talking” to each other)

Are you using both Cloudlfare’s plugin and CF APO? If so, does the “cf-edge-cache” response header appear for your site(s)?

Thank you!