Cloudflare Pages with Gitlab not working

I started trying to setup Cloudflare Pages with a repo from Gitlab however I wasn’t able to select my repo in the Pages UI. I just get an error like “API Request Failed: GET /api/v4/accounts/70d304bcdbbaaeb6ac5b353490132596/pages/connections (504)”

I tried revoking the Gitlab Access Token to see if it might let me restart but now it seems stuck.

It’s worth mentioning that my Gitlab has a lot of repos in it so that might be the issue but that’s not something I can realistically change.

1 Like

Hey, can you please join the Discord so I can get some info and pass this on?

Invite: Cloudflare Workers

I’m getting the same error

Hello, this is a known issue right now when you have a lot of groups/subgroups. The team is working on it and a fix should be out shortly!

An recent event, not sure if it could be related, but if I may just add as a notice here:
https://community.cloudflare.com/t/cloudflare-pages-build-delays/331422?u=fritex

Nah not related, that’s for the builds themselves not booting up or being very delayed. This is GitLab integration

1 Like

I am receiving the same error and wanted to check if this had been resolved yet to understand if its related to the issue I am seeing.

Hey,

This should be resolved, if you’re still having the issue could you please join the Discord server (Cloudflare Developers) and give me a ping?