Cloudflare Pages stopped working (500)

Hi! I have been using Cloudflare Pages for a few weeks now. Everything worked perfectly until a few days ago.

I made a small change in the codebase (literally added a tag somewhere) and when going to the preview site I received a 500 error. I merged to master thinking it was just a preview deploy bug, but the same happens in production mode. When comparing branches, the only change is that extra span tag, nothing else. In the end, I just reverted that commit and it started working again.

I have tried everything, even removing that last span tag and doing a small change somewhere else in the code, but the same happens. I tried updating my dependencies, changing the NODE_VERSION and YARN_VERSION, etc, etc.

The build log does not show any error, it ends in “Success: Your site was deployed!”.

Everything works perfectly in my local env. I moved back to Netlify and it works perfectly too.

I am using latest Nuxt version for my site.

Any idea of what might be going on?

What’s the URL giving the 500 error?

Hi! It is working now. Was told in the workers discord that it was some issue with CF compression.

Glad to hear that!