CloudFlare Pages page not working

Hello everyone, since a couple of months ago, everytime I go to my Pages page on Cloudflare the dashboard instead of showing all the projects I have working with pages shows nothing and this red sign on the bottom saying:

“API Request Failed: GET /api/v4/accounts/1972c9120ec0e6bad57aeeXXXXXXXXX/pages/projects?page=1&per_page=5 (500)”

Luckily I know the direct url access of all my projects (since it’s the same as the github repositories) and I can access them all by direct URL however I really wanted to solve this as it’s very annoying.

It also happens on multiple computers so it’s definitely not on the front-end side of things.

Can Anyone help me out?

Hey,

Have you change your GitHub username (or organization name) or transferred a repo from a user to an org (or vise-versa)?

Hello Walshy, I have not done any of the things you mentioned.

What happened a couple months ago was that I tried to create a pages project with a different name and it failed so I created it again with the same name as the repository and it worked.

I can’t access the failed one directly and it stopped showing all the projects so I don’t know what happened.

Can you send the account ID so I can send this up? The account ID isn’t private don’t worry

Hello @Walshy how do I check my account ID?

You can find it by signing in to the dashboard - the ID will be in the URL path.
image

1 Like