Cloudflare Pages Outage / Bug - Error 8000000

Hey there.

I think there’s a major bug with Cloudflare Pages that I’ve been experiencing for the past 24 hours (it doesn’t seem to be related to https://www.cloudflarestatus.com/incidents/0b7zypk3086q, as I’ve been experiencing this issue for the past 24 hours.

I’ve tried using the Dashboard & the API to create both a Git connected deployment as well as just a Direct Upload project, but both fail, so this isn’t connected to Github directly (even though I’ve tried to remove and re-establish that connection too).

On the dashboard, I get the following generic error and a 500 error in the Console:
An unknown error occurred. Please try again later.
Failed to load resource: the server responded with a status of 500 (Internal Server Error)

On the API, I get the following error:

{
	"result": null,
	"success": false,
	"errors": [
		{
			"code": 8000000,
			"message": "An unknown error occured. Contact your account team or Cloudflare support: https://cfl.re/3WgEyrH."
		}
	],
	"messages": []
}

I removed my existing deployment as part of the troubleshooting steps, so my sites are currently down and because this is almost certainly a Cloudflare bug, I can’t resolve this on my own and my support tickets get closed.

If this can be escalated / looked into, that would be amazing!

Hey,

What’s your account ID or a pages.dev on your account or a ticket ID?

Thanks so much for the fast response!

The ticket ID is #2867603 (contains screenshots)

My account ID is a3ffdaa01cda72ff6ff403b578d70d96

Thanks, it’s outside my working hours but I’ve added myself to your ticket and will get it moving tomorrow :slight_smile:

2 Likes

Perfect, thanks so much for your help!

1 Like

Hey,

Can you try and create a project again?

1 Like

Hey @Walshy

Unfortunately I’m getting the same error as before

Just to provide some extra context (if it helps)

I tried again to add a Github connected repository which gave the same error (so I tried to remove and re-add the connection), which gives the same result.

If you don’t mind me asking, would it be possible to know the reason behind this? It’s just a little unnerving for our sites to be down without much recourse.

You’ve been super fast in responding to me and I really appreciate that, but it’s a little scary that a core Cloudflare feature can just stop working.

Thanks again, I do appreciate your help!

3 Likes

Hello @user37612,

I have logged a new ticket for this and have engaged Engineering Team to check as well.

Please check your email for the new ticket details.

Thank you.

2 Likes

Thank you, I just received the email - really appreciate the response!

Some feedback if I may, it would be awesome to pay a one-time fee for priority quasi-enterprise support.

The problem is, I usually never contact support as everything is self-serviceable, so nothing has ever really required a need for special support.

However, in cases like this where it’s completely out of my control and the bug causes complete downtime and people are reaching out to me as our website is down, I would be more than happy to pay Cloudflare a fee to just get it escalated as a P1 ticket and solved (as opposed to not even being able to submit a ticket to begin with).

That would be awesome!

Sorry to post another message whilst a ticket is open, but I’ve been trying to troubleshoot / research in the background and noticed a few interesting things.

I’m curious as to whether this is the root cause of the issue.

For the purposes of separating billing, I’ve always had two CF accounts - one for my personal domain(s), and another for my business projects. I realized a few months ago you could have one user profile manage multiple accounts, so I merged these profiles (added my personal profile as a Super Admin for the business) and deleted the dormant user for the business account - which worked perfectly because now I can access everything from one login.

Could this be related to the issue - some sort of permissions bug? I tried to troubleshoot by adding another Super Administrator to the business account, but this also didn’t work.

Interestingly, I noticed a few days ago when the issue arose, that both the personal and business account could not create pages. When @WalshyMVP asked me to retry creating a project, I tried it on the business account as that’s where I need to create it (and it didn’t work).

However I’ve just noticed that project creation on the personal account is working when it didn’t before, so was a change made to the personal account ID instead of the business one?

If so, could the fix please be applied to the business account (the one referenced in the ticket), as I need to deploy a site to one of the domain in the business profile.

Thanks so much!

This problem still persists. Why is Clouldflare not fixing it. Cloudflare has become a nightmare.

I have the same issue