Cloudflare Pages - Failed: build exceeded memory limit and was terminated

Our Cloudflare Pages builds that we use for deploy previews are failing consistently starting at 2024-02-26T19:25:00.694319Z with the following logs:

2024-02-28T18:55:20.803117Z	Cloning repository...
2024-02-28T18:55:22.497055Z	From https://github.com/tackle-io/downstream-app
2024-02-28T18:55:22.497921Z	 * branch            abb1a3155d70d20d6f395de0aafc37a17ab8d2ac -> FETCH_HEAD
2024-02-28T18:55:22.498104Z	
2024-02-28T18:55:22.721941Z	HEAD is now at abb1a31 [GROWTH-224] Bump platform-ui to 2.0.1
2024-02-28T18:55:22.722476Z	
2024-02-28T18:55:22.819177Z	
2024-02-28T18:55:22.819853Z	Using v2 root directory strategy
2024-02-28T18:55:22.852541Z	Success: Finished cloning repository files
2024-02-28T19:04:17.502524Z	Failed: build exceeded memory limit and was terminated

Example build IDs
Earliest: 6ae18651-b78e-4189-9aae-f154373d397a
Latest: b9caf76b-76d5-4bb1-88fc-81dbccfdc7da

We previously experienced this symptom on January 10 when Cloudflare rolled out changes and opted us in to an infrastructure upgrade. Is this a similar issue as discussed in this thread?

Thank you for your help.

2 Likes

We also just hit the same. How can we opt out of these upgrades, or even opt in/pay for larger runners?

Started facing this issue from 2024-02-28.
Build IDs
77989350-dcd7-4f21-a660-8422dea6089a
d87d9229-6faa-473f-a446-b2a625876e93

@jhands1 @jfawcett Can you check this?
These are recent failing builds. also tried with --max-old-space-size=3072. which is also failing randomly.
b59c05e1-b84b-49b1-a1c9-7eeaa5827e3d
35261c88-1082-449e-a9ba-e2e1b030a622

1 Like

All of our builds are failing. Please look into this issue asap

It started from 1-2 days. It was random at first.
Now all the builds are failing.

relevant topics with no resolution

  1. Deployment failed build exceeded memory limit and was terminated - #6 by michael.tran
  2. Pages build failing - #3 by cloonan

Error is following

02:44:25.863
02:44:25.964
02:44:25.965 Using v2 root directory strategy
02:44:26.002 Success: Finished cloning repository files
02:50:17.595 Failed: build exceeded memory limit and was terminated

Please help urgently.

2 Likes

I’m also seeing this issue within the same timeframe

1 Like

We’re also experiencing the same issue since about a week. Around 9/10 builds are failing with “Failed: build exceeded memory limit and was terminated”.

Nothing in our repo has changed significantly in sizes.

Some builds:

  • 127b7f23-6baa-43b4-9055-2305f1226123
  • 1de39b50-aa87-4858-a1e6-f6a2a0c40f4b

Would really appreciate a fix.

1 Like

I ran a test to rebuild a build of a commit SHA that was previously successful, before we started seeing these errors, and it is failing with the same error as described above. This test makes me even more suspicious that this is being caused by a change on the Cloudflare side, and not our build.

The following builds were both from the same commit SHA:
Build ID that was successful: ea3e0a56-61d7-4787-bbf3-afe494547360
Build ID that failed: a758d842-c382-42dc-9e88-cbcb2c97296a

1 Like

We often encounter this problem. Here are some build IDs:

9825b359-fb66-49f6-a3c4-f42f9f791b79

cd4cda93-37ea-4b9d-afb9-f9971f09be5a

Could you please help me?

Thanks.

I added these environment variables to fix this issue.

Hi @jhands1 and @jfawcett ,

Our eng team is still experiencing this issue and it’s blocking our builds. We need to quickly get it addressed. Could you help or readdress to a Cloudflare engineer who can?

Build ID: 2a976edf-e217-47cb-a9bb-25a4c5ee8811

Thank you

1 Like

Build ID: 2b6d97e7-7d13-4458-809d-a3f8ecd02f1a

I tried to build using jekyll with more than 300000 pages and ran into the same error. I have no idea what are the limits of each build.