Cloudflare pages domain inactive

Hello i try to add domain to Cloudflare pages and it show inactive for almost one day.
If i access domain direct its show error 522
Remark
The domain is hosted inside Cloudflare DNS.
Add another different domain name is working normally
Domain: billbox(dot)me

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with Error 522 for your pages.

May I ask did you linked it in the Custom Domains section or you’ve done it manually?
It should be done through the Custom Domains setting.
If you done it there, what is the status of it?

May I ask have you added a CNAME record for your sub-domain and pointed it to custom.pages.dev ? :thinking:

Does the .pages.dev URL work?

May I ask you to either temporary Pause or switch the sub-domain record to :grey: (DNS-only) for next 6-12 hours, just in case (if the SSL certificate wasn’t generated properly).

UPDATE:

I can see it’s working, can you confirm?
If yes, may I ask how did you fixed it or what have you done? :thinking:

Follow your question

  1. I link it in the Custom domains section automatic without manually adding the cname record
  2. the status is Inactive (Error)
  3. .pages.dev is working normaly i also can point to my other domain or subdomain fine beside billbox(dot)me
  4. i just start to switch of record to DNS-only let hope the error gone by itself.
    5.the current screenshot is the main domain that point to my custom server. So i need to point domain accounts(dot)billbox(dot)me.

@fritex

I am afraid I might not know the right answer :confused:

May I ask my colleague @Walshy if he could take a look at this just in case as he is more experienced than me with Cloudflare Pages.

1 Like

Hey,

I’m a little lost on what should point where here. So, let me start by requesting some info:

  1. What’s the custom domain you’re trying to link and is returning inactive
  2. What’s the pages.dev this is pointing to
  3. Can you show what the DNS record is for that

As for what causes this, it usually happens when we’re unable to validate the hostname. This is usually blocked by something like a redirect or a Worker.

If you do have redirects or a Worker or something along those lines where it will intercept and change the response, please make sure to either exempt /.well-known/pki-validation/* or disable until your custom domain activates.

@Walshy

  1. I’m trying to point to accounts(dot)billbox(dot)me.
  2. I’m abit confuse here but maybe this is ? * billbox-authentication.pages.dev
  3. Here it is

So there is no solution @Walshy ?

@Walshy @fritex i’m still stuck on the current situation. Can you guy take a look ?