Cloudflare Pages doesn't work with custom domain (on cloudflare)

Hi, I’ve got an issue with cloudflare pages and using a custom domain.

My setup is:

  1. Namecheap is my registrar.
  2. I made a cloudflare zone and used all of the defaults. (I added it yesterday and deleted it and added it again today). It uses and
  3. I made a cloudflare page, that works just fine accessed directly.
  4. The page doesn’t work at all when accessed via the domain (which is setup via CNAME to the cloudflare zone).

But when I try to go to the website, it just fails it. I can’t access it on multiple browsers, my cell phone (not on network). I’ve tried reseting local DNS and I’m just out of options and don’t know what to configure.

When I navigate to the website on my cell phone, this is what I get.

But this makes no sense, it’s fully managed by cloudflare and uses cloudflare pages. What do I have to set to get this to work?


A custom domain doesn’t work on a CNAME alone, you need to go the Pages project settings and add the domain under the Custom Domains tab.

1 Like

The issue was that my DNS was cached on my local router, and therefore wasn’t working correctly. I set my machine’s DNS to and now it works.