Cloudflare Pages Deploy Failed due to an internal error

In recent days, the error occurs in about 3 cases out of 4:

it’s gatsby build, generating about 12k files including (4k images, PNG, AVIF, WEBP - small files about 10-200kB)

07:33:12.732 e[2Ke[1Ae[2Ke[Ginfo Done building in 568.617197728 sec
07:33:12.732
07:33:13.113 Finished
07:33:13.659 Deploying your site to Cloudflare’s global network…
07:43:32.572 Failed due to an internal error

My Pages failed with same error either. It’s a fresh new VuePress install with less than 20 files after render so I don’t think it’s gonna be a files number or size issue.

04:40:23.530	✔ Server: Compiled successfully in 13.80s
04:40:33.418	✔ Client: Compiled successfully in 23.70s
04:40:33.504	wait Rendering static HTML...
04:40:33.599	e[2Ke[1Gsuccess Generated static files in .vuepress/dist.
04:40:33.599	
04:40:33.635	Finished
04:40:34.087	Deploying your site to Cloudflare's global network...
04:40:39.878	Failed due to an internal error

This build’s uuid is b76502f1-8b1a-4fa3-8fd9-7cbfa99e4542 and if someone from Cloudflare see this please help us.

2 Likes

Same issue here… Hope we get some information soon! I’m not sure why it just says “internal error” – not a useful error message at all.

3 Likes

Same problem for me. It worked without problems until yesterday.

I have two projects:

  • Svelte SPA
  • Simple static one-page homepage with a custom domain

My problems since yesterday:

  • Preview deployments don‘t work at all
  • Production deployments work only sometimes
  • Redeployments of failed deployments don’t work at all

Hopefully we get a fix soon.

1 Like

Found a temporary solution in discord.
I switched on Web Analytics yesterday. After 1+ deployments I switched it back off and since then the deployments did not work anymore.
I switched Web Analytics back on and the deployments are working again.

This is just a workaround as I do not wan’t Web Analytics enabled. But it works for now.

Someone in discord said they deleted the project in Cloudflare and created it again without Web Analytics enabled. That way one can deploy without Web Analytics again.

I got that error the first time I tried deploying a Hugo site, it worked the second time. It also takes over 10 minutes to build, most of the time being in deploying to Cloudflare’s network, not in cloning the git repo. That’s simply way too long compared to rclone with AWS Cloudfront.

Now the custom domain CNAME verification is failing with the singularly unhelpful message “Inactive (Error)”. The record is correct, is it because of the CAA record? No clue, because of the useless error message.

Not impressed at all, this is not even a beta quality service.

Hi!
Thanks for tips.
I tried all variants with new project / web analytics enabled / disabled
but still got errors :confused:

Are you getting 5xx Error 500: Internal sever error?

No, error occured while building page,
its from build log
“Failed due to an internal error”

Website URL?

like week ago,
some build tries are succefull, but some failed

15:41:53.265 e[2Ke[1Ae[2Ke[Ginfo Done building in 628.675393476 sec
15:41:53.265
15:41:53.559 Finished
15:41:54.223 Deploying your site to Cloudflare’s global network…
15:50:53.558 Failed due to an internal error

thats build link, of course it should not be available for everyone

failed builds do not have links?

This is part of Cloudflare Pages which uses a build process to create websites. If you want to familiarize yourself with the technology it can be found here: Cloudflare Pages

You might ask this in the Discord channel, the Workers devs tend to follow it Meet The Workers Team Over Discord (cloudflare.com)

2 Likes

thanks,
Someoe on Discord gave me a hint - it looks like there are some hidden limits on Cloudlfare pages such: max build timeout 20 minutes
so 13.000 small (1-300kB) static files deployed to pages take more than 20 minutes to publish… and fail

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.