Cloudflare page mixed content. Not displayed correctly

Hello, it’s about the following.

I use WordPress with Woocommerce. I also use Cloudflare inkl (which is set to Strict)

Everything works only for a short time about 1 - 2 days. As soon as I go to the page it is displayed completely incorrectly.

The whole thing looks like this, for example, a small section:

Sometimes the problem is solved by simply waiting an hour and calling up the page again. But sometimes it persists and I issue the SSL to Cloudflare and then back to Strict. After 30min the whole thing works again … really funny.

What have I tried so far?

  • I defined the urls in the php-config (
  • I installed and uninstalled any WordPress SSL plugins.
  • I contacted the hoster who informed me that the problem was not with the hoster.
  • I tried to set the SSL from Cloudflare to flexible, but then I get an ERR_TO_MANY_REDIRECT redirection error problem.
  • I imported an older backup of my website.

None of this has worked.
Is there any way to find out where the error is, so without an error message etc I can hardly find out the cause.

If you need more information then just write and I will add it.

Thank you

My favorite solution (other than combing through site code and changing all HTTP references to HTTPS) is to add a CSP header to upgrade insecure requests:
Content-Security-Policy: upgrade-insecure-requests;

There’s a WordPress plugin that does this fairly easily:


Thanks for reply,

I made your suggestion but it didn’t bring much.

After 2 days it’s all messed up again.

I don’t know what else to do …

You haven’t posted your domain name, so I can’t offer more specific advice. Here’s general information:

Thanks but the site doesn’t exist or is private.Can it come from a DDOS attack? Unlikely or?

I don’t want to make the domain public, but I can send it privately.

This topic was automatically closed after 30 days. New replies are no longer allowed.