Cloudflare not working with Blogger subdomain

I have a Blogger blog on a subdomain. bloodiedwombat.heritagenetworkvic.com.au. The HTTPS isn’t working. Blogger keeps saying “Status: Failed - HTTPS SSL Certificate failed to be processed because of challenge data not being visible through the public Internet. Check your DNS setup. The operation will retry shortly.”.

I went through everything in Cloudflare and switched a few things on and off this afternoon, but I don’t really know what I’m doing and now The Blogger site won’t load AT ALL. It’s saying the site can’t be reached. DNS_PROBE_FINISHED_NXDOMAIN

There is no support for Blogger, and Cloudflare won’t support their product either. the entire IT industry runs on this sort of antihuman garbage. I am about ready to muder someone for wasting so much of my time and for providing no help with anything.

How am I supposed to get the damn site live again and how am I supposed to make HTTPS work with Blogger on a subdomain without needing a degree in computer science?

Though I have no idea how anyone is supposed to answer that without being able to access my account and look at the settings like a proper support team would do, so this is probably going to be a further waste of my unpaid time by the IT industry. Someone needs to take some resposibility for this sort of antihuman garbage - IT products that don’t work, then the company refuses to support anything and expects other members of the public to provide their support for them.

what the ■■■■ is going on NOW - now the main domain pages aren’t loading properly and there are errors in the inspector saying
Mixed Content: The page at XXXX was loaded over HTTPS, but requested an insecure stylesheet XXX/wp-content/plugins/cmp-coming-soon-maintenance/css/animate.min.css’. This request has been blocked; the content must be served over HTTPS”

WHAT ON EARTH HAVE YOU DONE TO MY WEBSITE??? THIS NEEDS TO BE FIXED, I DON’T UNDERSTAND ANY OF THIS GOBBLEDEGOOK.

Here is info for troubleshooting. Read:
https://support.cloudflare.com/hc/en-us/articles/200170476-Troubleshooting-mixed-content-errors
Check this #CommunityTip

You can also get more answers by :search: in the forum

Greetings,

Thank you for asking.

I am sorry to hear you’re experiencing an issue here.

Is it like a myblog.blogspot.com domain or?

Before moving to Cloudflare, was your Blogger blog working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Are you using a CNAME type of the DNS record?
Is it set to unproxied :grey: (DNS-only)

A topic with some helpful information and ideas:

Useful articles:

Additional helpful information here:

A Blogger Community says:

Cite:

To answer your question, YES you can use Cloudflare if you have a Blogger site with a Custom Domain but NO you can’t if you are using a *.blogspot.com address. You go to their website (cloudflare.com) sign up for an account (I recommend the FREE plan), attach your domain to Cloudflare, change the Name Servers from your domain registrar to Cloudflare’s Name Servers (Cloudflare will provide this information) and voila you’re good to go.

You can keep the SSL/TLS setting for your main domain “as-is” when it’s working for your naked-domain hostname or www domain hostname.

Nevertheless, using Page Rules, you can create a Page Rule and select an SSL option to configure different SSL/TLS setting (Flex, Full, Strict, Off) or disable it for a different hostname like sub-domain blog.example.com on which you’re trying to setup and configure your Blogger while not appyling the effect on your main doman.

Example, example.com and www.example.com are on Full (Strict) under the “SSL/TLS” tab of Cloudflare dashboard and both on HTTPS, while the blog.example.com is Off (HTTP only) via Page Rule.

Helpful article here:

Hi thanks for the detailed reply.
The subdomain is bloodiedwombat.heritagenetworkvic.com.au
Yes, HTTPS was working previously when it was hosted on Blogger.
SSL option is now set to flexible. It seems that when I switched it to Full that’s when the site stopped loading altogether, so I switched it back.
Yes, there is a CNAME record for the main domain in my DNS settings.
It is set to proxied.
there is no CNAME for the subdomain.
So I’m confused as to what the correct settings are.
The second part of your answer is far too technical for me to understand. I just need to know exactly what I need to do, based on the above answers.
Trying to load any of my blog pages is generating an error page saying “The site can’t be reached” with DNS_PROBE_FINISHED_NXDOMAIN.
This error was appearing when I set everything up initially but after waiting a few minutes everything was loading, but it was serving the site over HTTP.
Now it won’t serve any content at all, and I feel completely lost because I am not a developer.
I’m afraid I can’t see anything in those articles that could help me.
Any further help based on the above information would be appreciated.

OK the situation is NOW EVEN WORSE!!!
Cloudflare IS LOCKING ME OUT OF MY OWN WEBSITE BACKEND!

I can’t log in to Wordpress because trying to log in generates another f-ing error message.
The login screen is showing in unformatted plain text.
When I enter my details it brings up an error
" The information that you’re about to submit is not secure

Because this form is being submitted using a connection that’s not secure, your information will be visible to others."
But then when I click “Send Anyway” NOTHING HAPPENS!!!

What on earth is going on? You can’t lock me out of my own website!!

Why is absolutely everything broken all of a sudden? Can someone tell me how and what to fix URGENTLY??

There are also “Mixed Content” errrors showing all over the login page.
That help article says I should use a plugin in Wordpress as the solution, but I can’t even login to the site to do that!
This is just typical IT industry rubbish. Locking me out of my OWN WEBSITE and then making the solution dependent on my logging in when that is impossible. So much for “security”!
I’ve never had any problem adding Wordpress sites to Cloudflare before, and the site WAS working fine when I first added it.
Can someone please help me access my own website again?

I’d suggest you to:

  • Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  • The link is in the lower right corner of that page.
  • Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  • Un-pause once you’ve think it’s working.

However, write back if your WordPress is configured with “home_url” and “site_url” in the “Options” and working fine over a HTTPS in a different Web browser just for testing purposes.

If yes, then at the SSL tab of CF dashboard make sure it’s set to Full or Full (Strict) (Strict might not work if you’re using cPanel in some cases).

Maybe the SSL certificate expired and you need a new one at your origin host/server for your domain name to be re-issued/renewed.

What comes to my mind is the below one:

Furthermore, related to the Blogger, make sure the blog.example.com DNS record is :grey: (DNS-only).

I am willing to do this for you, however I’d have to have the needed access (Blogger, WordPress, cPanel/Web hosting, being a member of your Cloudflare account) which we could share privatly via PM/e-mail and post back here what are the steps which were done to fix your both issues as well as finding a solution on it.

Otherwise, you’d need someone from IT skills to double-check and configure this properly.

OK thanks, I was able to log in when I switched Cloudflare off.
I have now added the Cloudflare plugin to my Wordpress and set it to default settings.

after switching Cloudflare back on, I am now getting error messages “Your connection to this site is not secure” in Chrome on both the login page and the home page, but it does say my certificate is valid, and the mixed content errors have now gone.

Are you sure that I should set the SSL settings to “Full”? Because it seems like everything became broken when I made that switch, so I switched itback to Flexible. Everything was definitely working when I first set everything up on flexible.

As per my previous messages, there is no DNS record for the blog subdomain in Cloudflare. for some reason it’s only imported a tine fraction of the DNS records from my hosting provider. There is a CNAME record on the host server for the subdomain but not on Cloudflare. So I can’t switch that to DNS only.

So I guess the questions NOW, are

  1. How do I get rid of the "“Your connection to this site is not secure” errors on the main domain (why is it saying my connection is not secure if the certificate is valid?)
  2. How do I transfer whatever other DNS records are necessary from my host server, and why didn’t Cloudflare import those records correctly when the site was added?

PS the certificate that is showing on my site is from Google Trust Services, not from Cloudflare.

Common Name (CN)

*.heritagenetworkvic.com.au

Organisation (O)

Organisational Unit (OU)

Issued By

Common Name (CN)

GTS CA 1P5

Organisation (O)

Google Trust Services LLC

Organisational Unit (OU)

Validity Period

Issued On

Saturday, 24 September 2022 at 03:55:38

Expires On

Friday, 23 December 2022 at 04:55:37

Fingerprints

SHA-256 fingerprint

09 44 90 86 5E 83 8A E6 5D E4 C4 F9 5D FE C6 47 34 D1 FB A6 74 AC F1 A0 94 10 6E 4C DB 56 D0 B0

SHA-1 Fingerprint

67 B9 AC 34 5E 0A D0 9C D2 D7 E0 F8 6C D2 81 32 82 66 CF E6

That certificate is showing in Chrome, but in MS Edge, it says
"Your connection to this site isn’t secure

This site does not have a certificate.

Because this connection is not secure, information (such as passwords or credit cards) will not be securely sent to this site and may be intercepted or seen by others."

I have no idea what on earth is going on here now. Edge certificate and backup are both showing in Cloudlare.and the Universal certificate is active. The blog still won’t even load on the subdomain. Something seems very wrong somewhere.

OK, update - The home page is now saying it is secure on Chrome but the wordpress login page and backend pages still say they are insecure.
And all of the pages in Microsoft Edge are still saying There is no certificate.
And the blog pages still aren’t even loading. Still returning DNS_PROBE_FINISHED_NXDOMAIN

Can I PLEASE get some HELP with this?

I tried adding CNAME records for the subdomain and now I’m getting a different error

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

So I thought I’d switch off the proxy on the www. CNAME for the subdomain, and that produces a different error
Site Can’t be reached ERR_CONNECTION_CLOSED

This is slowly driving me insane, can I PLEASE get some help soon?

@adam8 Here I see this update:

You have enabled SSL on the site. Its working on the main page/home. It’s also working on the login page as well. (as I see now)

Do you have a A record for subdomain?

OK thanks for the quick reply - No, there is no A record for the subdomain on the host server either.
I just tried adding one, but it won’t let me because a CNAME record already exists for the subdomain.

The subdomain is now working on HTTP URLs. Switching off “Always Use HTTPS” in edge certificates seems to have helped.

OK so the main domain is now working, the only issue is the HTTPS errors in Blogger.

Blogger is still saying
HTTPS availability
Status: Failed - HTTPS SSL Certificate failed to be processed because of challenge data not being visible through the public Internet. Check your DNS setup.

Any further ideas?

May I suggest this for you?
Add A record in the host provider DNS record instead of CName & the same pointing here in Cloudflare.

Currently, if I may ask, have you proxied :orange: the A record for homepage?

It doesn’t appear to me as if you are using Cloudflare SSL.

@adam8 Cheers :grinning: You did it! Its working now.

Thanks so much for your help, I seem to have finally got everything working now.
Adding the missing CNAME records for the subdomain seems to have fixed everything.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.