Cloudflare not speeding the website up?

I am using the GTmetrix to determine the website speed and when I am inside of Europe(server is in Germany), the speeds are great, but outside of the Europe, there are significant slowdowns.

Found a few websites to determine the speed of my website from other places on this planet and determined that outside of places near server location, there are significant drops in speed. I am on the free plan, but my whole idea was that the website should be working a lot faster?

Here is the result:

Faster then what?
You actually just gave us the informations how your site is performing now, not how it performed before CloudFlare.

So even if you think your site is still slow, may CloudFlare have done its job and speeded up your site by a lot and you just dont know as you have not meassured it before?

What I would recommend:

  1. turn off proxy service (:grey:) for the domain you want to meassure
  2. meassure it with GTmetrix
  3. turn on proxy service (:orange:) for the domain you want to meassure
  4. meassure is with GTmetrix again
  5. post BOTH result links here so we can compare them

After this (with a before and after) analyse you can see what impact using CloudFlare has on your sites performance.
Your site anyway most probably is “dynamic” for at least your initial HTML request which is therefore NEVER beeing served by CloudFlare directly but have to be served by your origin server.

There is a workaround for this its called CacheEverything which makes dynamic content cachable. But you really should install the CloudFlare plugin on your WordPress installation therefore as it should be able to clear the Cache of Cache everything at changes

2 Likes

@M4rt1n thank you for the quick reply.

I have done as you suggested. Turned off the proxy service(DNS Only), checked that the domain is resolved properly for the server IP and have done the testing. The website has 1-2 new articles per week, so there isn’t that much of the content that needs to updated.

Cloudflare for Wordpress has been installed.

Here is the summary:
Capture

Here are the links:

Vancouver, Canada:
ON: https://gtmetrix.com/reports/knjigocrvic.com/b9Mwngej/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/Jd6dnbVg/

Hong Kong, China:
ON: https://gtmetrix.com/reports/knjigocrvic.com/3XZbwrof/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/HM67WBkb/

London, UK:
ON: https://gtmetrix.com/reports/knjigocrvic.com/ZKgE8xpm/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/t6jKbiOZ/

Mumbai, India:
ON: https://gtmetrix.com/reports/knjigocrvic.com/cbqbvLDh/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/OKz0QvUr/

San Antoni, USA:
ON: https://gtmetrix.com/reports/knjigocrvic.com/DrgaZjur/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/cY3cBgcV/

Sydney, Australia:
ON: https://gtmetrix.com/reports/knjigocrvic.com/zmRAzTDs/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/IdHhkT8M/

São Paulo, Brazil
ON: https://gtmetrix.com/reports/knjigocrvic.com/NLu0mPAV/
OFF: https://gtmetrix.com/reports/knjigocrvic.com/PpFzCeQP/

ALL of these Tests are not available for me, or at least access is restricted.
See:

Please post publicly available links/tests

Can you try now?

Ok lets talk about this example.

Here (as CloudFlare works as a ReverseProxy CDN) CloudFlare does not have your files Cached. To make it caching your files please do perform multiple tests, so the first requests will warmup your Cache and the second will then benefit from beeing cached.

Also: you are not using Cache Everything, which I would do as you said:

Therefor I would set it so 1 month and make sure the CloudFlare Plugin is activated and does clear Cache then it detects changes.
Thsi should solve your issue.

Then please run 2-3 times the test (from the same location!) to ensure you are meassuring CloudFlares performance and not your origin Server just proxied through CloudFlare :slight_smile:

So,
added the page rule:
knjigocrvic.com/

Cache Level: Cache Everything

Results are a little better:
1 - https://gtmetrix.com/reports/knjigocrvic.com/59HTrhHD/
2 - https://gtmetrix.com/reports/knjigocrvic.com/R8hOgeYO/

CA:


Auto Purge Content On Update turned on.

Should I add anything else? :slight_smile:

The speeds are a lot faster now.

https://www.uptrends.com/tools/cdn-performance-check??toolRequestGuid=b5ebb889-b1ab-4637-aa74-580dd26089c0

It looks like your origin has a significant delay when responding to the initial page request (even when Cloudflare is disabled), is this something you have looked into? (TTFB)

3 Likes

Nope, again this does not reflect what I wanted. As you most probably did not do exactly what I was recommended:

Your Testresults all show, that the the main problem comes from your initial request as @soldier_21 told. You can (and should) improve that with some static cache plugin, but to make this beeing fast worldwide you should activate Cache Everything with Autopure Content on update. But without Cache Everything your site will never be fast worldwide as it always have to be served by the origin server which takes more time for requests which have to travel longer.

2 Likes

Is there another option for cache everything as I am not aware?

No thats the option. Please try to run multiple tests now at GTmetrix (from the same location) to see CloudFlare improving your site performance.
Also you should set your EdgeCache TTL to maximum (in the PageRule), as it gets wiped on change.

I am in the process of testing catching plugins in order to reduce ttfb. If you have a recommendation, would be very grateful.

Got a WP fastest Cache premium and not to happy about it.

any tutor how to get the best performance out of CF CDN

Hm … here I have wrote how to speed it up:

How to get the best out of it depends on what you are focusing and what your needs & setup is. So to a variable target, there is no fixed path/way

2 Likes

So, I am testing further.


Amazing result. I decided to check few options with W3 Cache, I have additionally activated Automatic Platform Optimization for WordPress from Cloudflare.
Result:

Now I am totally confused.

Should the rules I added be deleted now or now? Is the Automatic Platform Optimization for WordPress doing all that automatically?

1 Like

Yes, APO takes care of that so you don’t need to use manual Page Rules if you have APO enabled.

1 Like

Thank you.

I will test it out.

W3 Total Cache + no page rules
W3 Total Cache + page rules for caching everything
APO without W3
APO with W3(current setup)

The limit on gtmetrix is slowing me down.

Is this cache everything really safe here? There may be more dynamic elements in html, which should not be cached. I don’t know if there are some, but there are some analytics for example.

Please be more precise on what is implemented, then I can give you a clear answer.
But if the analyse/tracking requests itself are not getting send to the Domain which you set the cache everything on, this should be fine.