Cloudflare not showing up on my ezoic dashboard


I integrated with Cloudflare today. First, my site has stopped loading on the desktop. It’s showing an error.

Second, I want to integrate ezoic via Cloudflare on my website. But the Cloudflare integration option doesn’t show up on my ezoic dashboard. Please help with both the issues!

Can you provide a little more information? What is your website?


Thank you for asking.

Regarding eZoic integration through their dashboard (interface), have you re-checked, as far as I remember, they asked you to provide either your’s Cloudflare credentials, or, it could be they have updated something, and they are asking for Cloudflare Global API key?

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Furthermore, have you already followed the articles below?:

There are two ways as I remember:

  1. Going with Cloudflare integration and having Cloudflare nameservers
  2. Changing domain nameservers to eZoic ones and then using their interface to apply all and any changes regarding the Cloudflare dashboard

Further more, upon successfull integration, just to take a note here as any changes you would want to make for your domain, you would have to do it through their eZoic interface.

Otherwise, if you change something at Cloudflare dashboard, but not through the eZoic interface, it will be reverted back to originals (there were few topics about where people have had changed or added a new or existing DNS record and it was removed somehow without a notice).

Maybe some other helpful topic about eZoic here at Cloudflare Community using :search::

Unfortunately there were some topics before regarding people having some errors or issues with eZoic and Cloudflare integration.

Thank you so much Fritex! I’ll just try again with what you’ve suggested!

Beardedrazorback, it’s roomyoulove(dot)com

I tried to log in to my ezoic dashboard through my phone, and incognito window but the Cloudflare integration option isn’t showing up.

And I cannot add my Cloudflare account details unless the option shows up. Please see to it.

My site is roomyoulove(dot)com

The Cloudflare option is still not showing up on my ezoic dashboard. Any update?

May I ask have you tried writing a ticket to eZoic support about this case? :thinking:

Yes! I have written to them, already! They’re looking into this now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.