Cloudflare not serving correct

I have setup cloudflare using nameservers.
However:

  1. I still see images being served via my wordpress.
  2. I don’t see any significant improvement in pagespeed.
  3. I believe something is not setup correct and I don’t know what or why.

Can someone please help me?
What am I missing here?

Thanks!

It looks like your site has been configured to disable caching.

oh thank you, I have a wordpress site , how can that be the case?
Isn’t cloudflare returning that?

@sdayman but if I make cloudflare the dns and first point of contact, would it control the cache control? or do I need to just add cache control headers to my backend for this to work (I’m using wordpress)?

Do you have any Page Rules set up? That’s the only way to override whatever you’ve done on your site.

@sdayman No I don’t have any rules setup.
What rules do I need to setup?

However I think now I fixed the backend, and no cache busting is happening.
Can you please have a look from your end?

That’s better. It would be much faster if your .js files didn’t keep changing the version numbers in the query strings. Cloudflare cache tracks by that query string. So if you use Autoptimize’s “Extras” settings to turn off query strings, that should help quite a bit.

Then the only thing that wold hold things up would be the main HTML content from your pages.

I have cloudflare turned on for my website :slight_smile:

However I still see very high ttfb (1-2 seconds).
Why is that? Wouldn’t cloud-flare eliminate that?

This topic was automatically closed after 31 days. New replies are no longer allowed.