Cloudflare not caching my site

I use this Page rules:

But Cloudflare is not caching anything:

Can you help me about it?

PS. This is my other rules in Cache section

Drop the protocol and the period after the asterisk in the first rule (just *highrevads.com/*). Also, drop rules #2 and #3 and use the global setting instead.

1 Like

Post a screenshot of the new rules, just to make sure :slight_smile:

Still the period after the asterisk :wink:

Right, done!

I’ll update this post.

Just make sure you did turn on your global “Always use HTTPS” setting, otherwise it wont redirect HTTP requests.

Your main document still does not seem to get cached, but that will be most likely because of the cache control directive your server seems to send (Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0) and which instructs Cloudflare not to cache.

Either remove that header from your server configuration or play with additional caching settings in your current page rule.

This topic was automatically closed after 30 days. New replies are no longer allowed.