Cloudflare normalization not working

Hi all! I’ve tried disabling normalization, but it doesn’t work. If I type something like “my-site///tester.php///” in browser, I have normalized url in my server (echo $_SERVER[‘REQUEST_URI’] → /tester.php/) If I enable normalization I have same behavior. How can I get not normalize uri?

You can’t completely disable URL normalization on Cloudflare.

I’m having an issue where I switch normalization type from Cloudflare to RFC3986 and then refresh the page, within a minute it’s back to Cloudflare. How can I make it stick with RFC3986. Obviously if the option is there to switch it should allow us to change it.

The cloudflare option breaks our website WAF that looks for malicious urls including those that have malformed urls but cloudflare attempts to correct them allowing a few of them to go through. It actually breaks their own WAF as if you create a rule to block urls containing “//” and cloudflare normalizes the url, it won’t block them and I can still see the request containing the “//” in the server log.