Cloudflare Noob - SSL Help Needed

Host:
Network Solutions

DNS Pointed to Cloudflare successfully
SSL / CLoudflare says everything is good to go

Browser unable to use https

Not sure what I am missing, using Flex
Any help appreciated.

Can you share the domain?

1 Like

VelicoMedical.com

1 Like

On the Edge Certificates tab of the SSL/TLS app of the cloudflare dashboard, can you turn on Always use https? Looks good to me…

1 Like

I’d like to - I’m currently on Flex / without force ssl because it is failing on my end for firefox and edge browser currently - I haven’t checked chrome / safari / others at this time, awaiting a pass on my end for firefox.

Think it’s a simple propagation issue?

Propagation is complete, the site is active and the certificate is issued. Try clearing cache, an incognito window, and/or a mobile device.

1 Like

This tip speaks to the ssl protocol error you’re getting, Community Tip - Fixing ERR SSL PROTOCOL ERROR. I’d try quick fix idea 5. Can you disable TLS 1.3 on the edge certificate tab of the SSL/TLS app on the cloudflare dashboard?

Edit - Now we’re making progress. I see 1.3 is disabled and the protocol error is addressed, but you have mixed content with a script. Normally, we’d use Automatic HTTPS Rewrites to address mixed content issues, but that switch won’t affect scripts. Lots of details on how to address on this site and in this #CommunityTip, Community Tip - Fixing mixed content errors and this #Tutorials, Mixed Content.

1 Like

I wish I was getting as far as you have on this - my screens on all my devices are still showing the initial error, I have not been able to see the https load at all still - I can’t continue until I see the working https on my end. I’ll keep you posted.

Did you clear cache or try from an incognito browser? You can enable Always use HTTPS on the Edge Certificates tab of the SSL/TLS app. That will force the site to load over https.

1 Like

Yes, I’ve tried the mentioned options, including trying from my linux vm with the same result. Very strange.

This topic was automatically closed after 30 days. New replies are no longer allowed.