CloudFlare modifying server response?

I have a website I am hooking up to an ad network. They said I need to use CF to remove/reduce bots.

I got everything hooked up and assumed it was working. Turns out either CF or the ad network is modifying traffic from the server.

My site is highly dynamic and as such uses a lot of jsonp. I should get a response from my server to the site that looks like:

jQuery19109311104061858169_1645367743876({"us

However, my response is being transformed into:

<html><head></head><body>jQuery19109311104061858169_1645367743876({&#34;us

As you can see something is encoding quotes and adding extra HTML tags. Since I am new to CF, can someone please let me know if there is a setting or something that I need to turn off in CF, or is this related to the ad network?

I have never seen Cloudflare HTML encoding anything in the body of a response.
But feel free to provide the URL where this is happening and we can have a look at it.

I am not sure why the URL is needed (but I can provide it to you). This issue has been resolved temporarily because I reverted to nameservers directly to the host. I also manually added NS DNS entries to CF (not sure if they have helped or not).

Is there ANYTHING OOTB (Out of the Box) that would alter payloads? I am venturing no but just want to confirm as my contact at the ad network is OOO right now.

Greetigns,

Thank you for asking.

May I ask, eZoic or some other?

Are these GET or POST requests?

Is maybe the Auto Minify option or Rocket Loader option enabled at Cloudflare dashboard?

Furthermore, how about security options like Bot Fight Mode or some similar?

Maybe it’s related to the URL normalization? :thinking:

See here:

Meaning, you have created NS type of DNS records with hostname/target to your old nameservers at DNS tab of Cloudflare dashboard for your domain name?

1 Like

Ezoic is the ad network.

  1. Ezioc is the ad network
  2. It depends, mostly GET. This is the primary issue as the site is retrieving data for the user.
  3. I do have Bot Fight Mode on, but also created a rule with “Cache Level: Bypass, Disable Performance” for the entire domain.
  4. I set the NS on the domain itself to be the host environment. I also manually added them to the DNS entries in CF, but I doubt they have any impact. Was hoping to make the switch over quicker.

There are two primary ways to call the service. file.php? or domain.com/api/add/a/bunch/of/other/stuff/here/as/key/value

Are you trying to activate and integrate Cloudflare for your domain name using eZoic interface and “their nameservers”, otherwise not using their integration method and manually adding their “cdn” hostnames to the DNS tab of your domain name under your Cloudflare account? :thinking:

All I did for it was connect CF to my existing setup. Then tied or gave EZ access to CF. EZ did something, but then have been waiting for their network quality team. I had tested everything out before hand but it was working under false pretenses because my network traffic itself hadn’t switched.

I didn’t add anything to CF for EZ, but maybe their connection did.

I am still 99% sure it is an EZ problem (even though I have blacklisted pages/URLs).

May I ask have you reached and contacted eZoic support via their Support center / ticket about this? :thinking:

I have not. I have a dedicated rep I go through. But it is all turned off for now, and no one mentioned CF having anything they are aware of so I will assume it is their problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.