Cloudflare + M365

Hi All,

Been having issues lately with DNS records with my previous host. I moved across to Cloudflare and all was working. Then suddenly my CNAME records for DKIM stopped resolving after running


I spoke to MS and we decided to remove the DNS records and re-add them.

The records have been set to TTL of 3600, but still no luck. The records are NOT being proxied either

I have since re-done this and they are still not resolving - this is almost on 2 hours now.

My laptop DNS is on to try speed the process up somewhat rather then relying on my ISP.

Any ideas on next steps?

Its been almost 4 hours.

According to MX Toolbox the CNAME’s resolve to the above, yet still cant NSLOOKUP those records?

It’s been some more hours since you wrote, and they do also seem to work just fine from my end.

Are you still having problems?

Is it also on this specific laptop you saw issues with the DNS resolution?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.