CloudFlare lost my dns zone!

Today we discovered that the site has become unavailable. We went into the panel and saw that the site was gone. At the same time, we did not receive any letters.
No errors, no any letters. Just site are gone.

Hi @promoneyclub,

It should not have been removed from Cloudflare without action or notification.

Can you:

  1. Post the domain
  2. Check you are definitely logged into the correct account
  3. Check with previous emails from Cloudflare that the email they were sent to matches the email you are logged in with
  4. Check the audit log for any signs of the domain being removed
1 Like
  1. promoneyclub.ru
  2. yes
  3. i see emails in inbox
    4 where?
    I see talks about migrate at 06.08.2019

Do you see any previous emails from Cloudflare relating to the domain in question? If yes, can you check that the email these were sent to matches the email you are logging into Cloudflare with?

You also seem to have 4 nameservers assigned for that domain.

nserver: ns1.wspb.ru.
nserver: ns3.wspb.ru.
nserver: venus.ns.cloudflare.com.
nserver: zod.ns.cloudflare.com.

For Cloudflare to work, you need to have only the 2 assigned Cloudflare nameservers.

We need CF only as dns server with API manage, not as http proxy. And it worked for about 2 months.

4
Date:

2019-10-27 11:50:45 (GMT+3)

User IP Address:

127.0.0.1

Resource:

Zone

Audit Record:

db1b1f01-29f7-5c2e-b078-55dcf1d2babe

Metadata:

{ "Zone name": "promoneyclub.ru" }

(action: PURGE)
No any warnings, no any emails, no dump zone in email for recover. CF just purge our zone.
Where at least 3 warnings with reasons (and yes, we WANTS use CF without proxy, just as dns service), where dump zone, where email about purge?

I suspect it was purged when the nameservers no longer solely pointed to Cloudflare. You should have received an email warning that the zone would be purged. Why you wouldn’t have received that, I can’t tell.

2 months nobody changed anything, it could not break suddenly

It’s weird, I ran the dig command a few times within a few seconds, and sometimes I got the Cloudflare nameservers, and sometimes I didn’t.

[email protected] ~ $ dig ns promoneyclub.ru +short
zod.ns.cloudflare.com.
venus.ns.cloudflare.com.
[email protected] ~ $ dig ns promoneyclub.ru +short
zod.ns.cloudflare.com.
venus.ns.cloudflare.com.
[email protected] ~ $ dig ns promoneyclub.ru +short
ns2.wspb.ru.
ns1.wspb.ru.
ns3.wspb.ru.
[email protected] ~ $ dig ns promoneyclub.ru +short
zod.ns.cloudflare.com.
venus.ns.cloudflare.com.
[email protected] ~ $ dig ns promoneyclub.ru +short
zod.ns.cloudflare.com.
venus.ns.cloudflare.com.

I have not seen this before.

It doesnt matter for how long it might have worked. The underlying issue is your domain never validated on Cloudflare in the first place, as you never had a correct DNS setup.

That will also be the reason why Cloudflare finally purged it. You need to set it up from scratch and make sure this time that you only have the nameservers Cloudflare will give you.

1 Like