Cloudflare keeps redirecting to wrong site (cache?)


#1

Hello ! Im using the free version of Cloudflare. Some time ago I had this domain in Porkbun, foo,com, and I set up an url forwarding to bar,com . It was working pretty good, and later I made the same setup using Cloudflare instead of Porkbun for foo,com.

But now I dont want the url forwarding anymore, so I just set foo.com to resolve to my new server ip and I added some subdomains stuff,foo,com and example,foo,com to the same ip.

The subdomains are working great. But foo.com still redirects to the old bar,com.

I have tried purging the cache in Cloudflare and Chrome, I have also tried to access foo.com from several different computers, but still the same behavior. It only works when I pause the website in Cloudflare ("… Cloudflare will continue to resolve DNS for your website, but all requests will go directly to your origin …")

Any ideas about how to fix this problem ?
Thanks


#2

Do you have a Page Rule for foo.com that forwards to bar.com?


#3

You are right. There was a page rule still active and somehow I forgot to check. I assumed the rule would have been deleted when some time ago I deleted the configuration for my domain and added it again. Classic mistake.

Thanks


#4

This topic was automatically closed after 14 days. New replies are no longer allowed.