Cloudflare is refushing access to legit "Firefox Ubuntu Linux" browser, and doesn't alllow to create a support ticket for it

No the problem is not solved why the F, does the bot pretend the problem is solved even though this is a general Cloudflare issue and not domain specific…

It seems Cloudflare is bouncing the request due to not liking my real/true “User agent” :

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

When faking my "User agent"to “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0” (With User-Agent-Switcher) I get past the Cloudflare reloading headache.

It seems Cloudflare is refusing access to legit Firefox Ubuntu Builds that come from the genuine Ubuntu repository.

Hi @allemaal_onzin,

What plan are you on? If you’re using Cloudflare for free, your plan does not include access to support (unless it’s a billing, registrar or abuse issue) so opening a ticket will redirect you here.

If you’re getting a challenge screen, you should see why that challenge is occurring in your firewall events log and be able to change your settings to avoid that.

Or is the issue that the challenge is looping on that browser? If so, can you try in a private window and see if the result is the same?

I don’t own a website at all…

[Rant mode on] This annoys the ■■■■ out of me that you can not report a problem with Cloudflare if you don’t own a website, and you can just suck it up apparently, who cares right if Linux/Ubuntu Firefox users get shafted. [/Rant mode off]

There are specific Cloudflare protected websites that seem to block Firefox, simply based on Cloudflare not liking the User Agent of the genuine Firefox build as supplied by Canonical through the genuine Ubuntu repositories (iaw to all Ubuntu Firefox users).

I can see this because if I change my User Agent with an Add-on to a Windows Firefox User Agent, the website(s) stop blocking me (the looping goes away).

This no longer existing website (but existing for Cloudflare) shows the problem:

Just change your User Agent to the genuine: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

You will see you get blocked.

Other Linux browsers, Chrome, Chromium & Opera, don’t get blocked, so it is not like they(the website owner/who ever) want to block everybody who comes from Linux, apparently Canonicals Ubuntu Firefox User Agent simply isn’t being white listed by Cloudflare.

:dizzy_face: cloudflare

I just tried the supplied URL as browser default, and using the exact UA you supplied. I get an identical behaviour in both cases - Cloudflare 5s delay, then redirects to the URL with a 404.

That is interesting, thanks for testing, so there must be more going on then just the “Browser User Agent” ???

I just retested again my self and I get a different result now.
As long as the default Firefox Ubuntu User Agent is used I can not get through to the page (In Firefox, all my other browsers get through)
Now when I selected a fake Windows Firefox User Agent, I get to a Captcha page, that Captcha page I had to do 3 times (It reloaded back to a new Captcha challenge after solving multiple Captcha’s) and then I get to a blank page with out a 404 error showing… (This didn’t happen before)
I tested it some more times and randomly I do not get a Captcha challenge at all, or after some time I get either a Captcha or I get through to the webpage (as long as the User Agent isn’t the default Firefox one)

When I start Firefox in Safemode I get back to the endless loop again, never hitting the webpage.

I wanted to see what would happen in Chrome if I altered my User Agent there to “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0”

I get through to the 404 Error page without any Captcha challenge, I am completely miffed what is going on here …

Somehow this is only happening in the Ubuntu Firefox browser and not in other browsers, and it is happening even in safemode… (Bangs head against a wall)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.