Cloudflare is not caching the library URL

Hi everyone,

We are having a server deployed on Google App Engine Standard environment. The simple server serves a JS library on the endpoint ‘/’

  1. We have added a CNAME at Cloudflare
  2. In the Google App Engine, we have set the dispatch Route to the CNAME.

It seems like the Cloudflare has the chance to cache the resource but is sending a ‘Miss’ in cf-cache-status

This is incurring us cost on the App Engine Instance.
Any help will be appreciated.


There could be a conflicting cache header. What’s the URL?

1 Like

Thanks @sdayman
Here is the url:


Nothing in the headers jumps out at me. Maybe @matteo has used Google’s App Engine, or @cbrandt might see something in the headers that’s preventing caching.


Same as you… never used App Engine, but it’s not the server that creates a problem once you give out the headers.

Probably best would be to ask support directly. Maybe there is some header that Cloudflare strips or some setting in the dashboard that prevents caching.

The Expires header seems to make it expire instantly. Try removing it.

For me it’s 1 month ahead though…

This is what I’m seeing:

Absolutely correct. My bad, I must have got the month wrong :blush:


@aayush1, would you feel comfortable sharing the hostname where your CNAME is pointing to?

1 Like

Oh, gotcha.

You App Engine instance is sending a cache-control: public, max-age=0 header. That will prevent Cloudflare from caching it. You should be able to overwrite it in the dashboard (it will impact the whole website), but il will be way easier to do so in the server’s config.


Thanks, I will check this.