Cloudflare is ignoring Firewall Allow rules

Hello!

Cloudflare has failed to follow the rules I set to my firewall a few times in the past, but it’s been getting worse the last week or so.

I’ve tried to add different rules to solve the problem, but still they are sometimes ignored.

In the image below, you’ll find:

  1. A simple case where a request that should’ve been allowed was blocked:
  2. My rules in order. Note there is no Block rule that could’ve been messing things up.
  3. A couple of rules that I believe were ignored

Am I doing something wrong? I appreciate any help!

Thanks in advance!

Greetings,

Thank you for asking.

From the screenshot above, service Browser Integrity Check is blocking the request of Jakarta Commons-HttpClient/3.1.

Have you tried temporary disabling the Browser Integrity Check option at Cloudflare dashboard by navigating to the Security tab → Settings? :thinking:

I am afraid the order and priority of rules might be the thing here from link below and picture for explanation:

As far as Firewall Rules execute before, they allow it, but Browser Integrity Check blocks it.

Nevertheless, I’d suggest you to whitelist the origin host/server IP at Cloudflare → Security → Tools → IP Access Rules with the action “allow” for your Website.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.