Cloudflare is blocking sitemap.xml

Hi,
I have problem with adding sitemap.xml to Google Search Console.
I get 403 error.

When I turn off proxy in cloudflare DNS settings than it is working fine so it have to be something with cloudflare.
I have also second website with cloudflare and everything is working fine.
I set the same settings on cloudflare basing on website where everything is OK but it didnt help.
Even when I am checking this sitemap here: https://httpstatus.io/ I still getting 403 error.
Link to sitemap is: https://cryps.pl/sitemap.xml

My website is based on WordPress.

I dont want to resign from Cloudflare but it have to work properly.

What is also funny 403 error is showing only when you will use Googlebot 2.1 (Desktop). Other bots and also Google Mobile bot is working normally (200 response).

I am using also Wordfence, but even after deactivation of this tool the problem still exist.

1 Like

I don’t know why this would be, but have you tried adding a page rule specifically for the sitemap and tweak the settings in there? Perhaps reduce the security level or bypass cache, to try and determine what it is about the Cloudflare configuration that’s affecting it?

Cloudflare itself doesn’t return 403 errors, this must be coming from your origin server. How is your sitemap produced? If it’s Wordpress, I’m guessing a plugin is generating it?

OK, problem solved. Something was wrong with hosting. I changed it and now everything is OK. Hosting support couldnt help me so I decided to change it.

This topic was automatically closed after 14 days. New replies are no longer allowed.