Cloudflare is blocking Ezoic Network

Cloudflare is blocking Ezoic Network.
I have integrated Ezoic Network through cloudflare but when Cloudflare’s proxy is enabled, visits are not able to be routed via Ezoic. It seems something at Cloudflare is blocking Ezoic.
Host support team has already checked everything from their side and confirmed that each record from their side are properly pointing to cloudflare.
How can I resolve this issue?

Take a look at your Firewall Events Activity Log. It should should the blocked traffic, and clicking on the log entry should show you the setting that’s blocking the request.

For more info, there are many posts about this:
https://community.cloudflare.com/search?q=ezoic%20block%20order:latest

2 Likes

I have gone through the posts after clicking on the link, but didn’t find the solution. I am not sure what to do next now?

:+1:

Did you :point_down:

1 Like

If you are talking about Cloudflare’s firewall section, I don’t find any activity log there. If it is not the case, could you please tell me where to see for firewall activity log?

What does “visits are not able to be routed via Ezoic” mean exactly?

1 Like

Ezoic ad partner is unable to integrate the display of ads into the website.

I have absolutely no idea what that means. Is there an error message of some kind on the web page? What leads you to believe Cloudflare is blocking something?

Also if Ezoic support (ha!) believes it is a Cloudflare issue please ask them for details as to how they determined that. Their support tends to be based on some interesting interpretations of how technology actually works / should work on occasion.

3 Likes

Sure. I am going to ask them these queries and share their response as soon as they provide it.

2 Likes

Below is the reply from Ezoic

On Ezoic’s end, we have a way to see whether sites are using our proxy or not, and even though everything is set up correctly for your site to be on our proxy, it is not using it, which leads our tech team to think something is blocking it. This is an unusual case because normally there aren’t settings in CloudFlare that can block our proxy, besides the CloudFlare Workers that we already asked about or if your site is using CloudFlare load balancing features. Could you confirm for me that you do not have Rocket Loader or Automatic Platform Optimization turned on at Cloudflare?

It’s also possible there’s something set up at your host that makes it so the host server is always hit directly, which means Ezoic’s proxy would not be used, but our team has no way of knowing what that might be.

It looks like that is a post in CloudFlare’s support community. If possible, you would likely need help from a CloudFlare support agent who would be able to take a look at your settings for anything that might block proxies. Alternatively, you may need to reach out to your host and ask if they have anything set up that blocks your site from using proxies.

May I ask do you use any plugin for cache at your WordPress Website?
Or a Page Rule with Browser Cache TTL and/or Cache Level: Cache Everything?

If related to, may I share this post:

But, neither you cannot allow each IP range manually for eZoic (tons of them!), see here:

Hi,
Rocket Loader or Automatic Platform Optimization is not turned on at Cloudflare.
Using WP Rocket at WordPress Website. I had already integrated Ezoic via DNS change method & ads were properly getting displayed and no any other issue observed even after using WP Rocket. Now I integrated ezoic via cloudflare proxy method and it’s not working.

‘Standard’ Cache level is set at Cloudflare.
DDos and bot protection are also disabled at cloudflare.

ticket number 2346632 @MoreHelp

Please help me resolve the issue. Latest reply that I got from the Ezoic support team is:

" The issue with having the CF proxy on is that requests are actually bypassing Ezoic and hitting Cloudflare first . Unfortunately, we don’t really have visibility into why that is but its’ something set up with either Cloudflare or your host."

So this isn’t a blocking issue. That’s very different.

Who’s your host?

1 Like

Thanks for your confirmation. Bluehost is my host. I also check with them and got confirmation that everything is fine with their side. Could you please suggest me if I need to check for any specific setting with them?

Are you using Bluehost’s Cloudflare integration? There’s usually some setting at Bluehost that indicates you’re using Cloudflare.

1 Like

No, currently I am not using Bluehost’s Cloudflare integration. I can also check from my bluehost’s account that it is already disabled.

I still suspect it’s routed through Bluehost’s Cloudflare system.

Open a ticket here via email support AT cloudflare DOT com and ask them to remove any SaaS setting for your domain. Post the ticket # here as soon as you get the autoreply so we can escalate it.

1 Like

Ticket # 2349344