Cloudflare IP class issue

wordpress

#1

Hi,
As soon as I enabled the free Cloudflare for my website a whole IP class for one of my country’s ISPs was denied access to my website. The message I got was “web page takes too long to load”. When I enabled it I left all Cloudflare settings on default. As soon as I pause cloudflare the website is reachable. Any suggestions would be appreciated.


#2

Where is your site hosted? And is that the same country of your ISP?

Can you also run the following command? (Replace example.com with your domain name)
curl -svo /dev/null https://example.com

And post the output. You can edit out the domain name if you’d like when you post the output.


#3

The site is hosted at Bluehost. The country of the ISP is different than Bluehost.
This is the result with Cloudflare disabled:
C:\WINDOWS\system32>curl -svo /dev/null www.trpceski.com

  • Rebuilt URL to: WEBSITE
  • Trying 70.40.218.41…
  • TCP_NODELAY set
  • Connected to www.trpceski.com (70.40.218.41) port 80 (#0)

GET / HTTP/1.1
Host: WEBSITE
User-Agent: curl/7.55.1
Accept: /

< HTTP/1.1 200 OK
< Server: nginx/1.14.0
< Date: Wed, 18 Jul 2018 22:43:52 GMT
< Content-Type: text/html; charset=UTF-8
< Content-Length: 88458
< Connection: keep-alive
< Vary: Accept-Encoding,Cookie
< Cache-Control: max-age=3, must-revalidate
< Last-Modified: Wed, 18 Jul 2018 22:43:47 GMT
< X-Acc-Exp: 3
< X-Proxy-Cache: MISS WEBSITE
<
{ [4044 bytes data]

  • Failed writing body (0 != 4044)
  • Closing connection 0

(I don’t mind posting the site, I edited the name bc it doesn’t allow more than 2 links)


#4

This is the result with Cloudflare enabled with all default settings:
C:\WINDOWS\system32>curl -svo /dev/null www.trpceski.com

  • Rebuilt URL to: WEBSITE
  • Trying 104.27.168.49…
  • TCP_NODELAY set
  • connect to 104.27.168.49 port 80 failed: Timed out
  • Trying 104.27.169.49…
  • TCP_NODELAY set
  • connect to 104.27.169.49 port 80 failed: Timed out
  • Failed to connect to WEBSITE port 80: Timed out
  • Closing connection 0

#5

It seems to me the ISP has blocked access to that Cloudflare IP address.

Do you have any other sites on Cloudflare you can connect to?


#6

I was talking to my ISP for 2 days and they were stumped. They said they have no blacklisted or blocked IP addresses regarding my site. I also spoke to Bluehost and they too said they have no blacklists or blocks regarding my ISP IP addresses. Bluehost escalated the support ticket and later sent me an e-mail saying:
I am following up on your ticket regarding issues with accessing your website. Currently, I am not seeing your local IP (x.x.x.x) blocked anywhere on our server. At this time, the website does load for me, though I do see that you have it routing through Cloudflare. It could be entirely possible that you may be caching a previous error. I would recommend logging into your Cloudflare dashboard and clearing the cache, as well as that of your browser to be certain.
That’s all I got.


#7

That was pretty thorough of all involved. I only have two more ideas:

  1. If you’re friends with a neighbor on the same ISP, try it from their home. Same goes with others in your region on the same ISP.
  2. Open a Support ticket. Maybe Cloudflare has a way to test from that ISP.
    https://community.cloudflare.com/support_request

#8

Yeah, I did talk to several people who are on the same ISP, none of them can access the website. The strange thing is, the ISP is also a telecom company providing mobile network. The site can be accessed over cell phone on their data plan. So the issue is only with cable internet from this ISP.
I will open a support ticket.
Thanks for the help, much appreciated.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.