Cloudflare iOS issue

My site https://earguru.in/ is not working on iOS after enabling Cloudflare’s APO.

It works on other platforms but not on iOS (Tried using chrome too).

It’s working for me on iOS 14 (Safari).

1 Like

Hi,

Thanks for responding.

As mentioned in my mail, we have deactivated the APO. The site loads fine without the APO.

We can activate APO at the given time or give you Admin access so you can activate and check.

Regards,

Amrik

Hello,

The APO is activated.

Kindly check and let us know where we are going wrong.

Regards,

Amrik

The site doesn’t work in desktop and mobile Safari without APO as well.

1 Like

Hi,

Site does not load on iPhone with APO and Proxy disabled.

We have disabled Proxy and APO. Now the site is loading fine.

Kindly advise on the next step.

Regards,

Amrik

Sorry, disregard earlier mail.

Site does not load on iPhone with APO disabled and Proxy enabled.

We have disabled Proxy and APO. Now the site is loading fine.

Kindly advise on the next step.

Regards,

Amrik

I suspect that’s not related to APO, could you enable Cloudflare on your zone without enabling APO? So I can diagnose the issue?

I did it earlier, The whole time APO was disabled and Proxy was enabled.

It was still not loading…
If CF is not working then APO will obviously not work.

that’s what I thought, I actually don’t have any suggestions how to fix your Cloudflare setup.

Cloudflare setup seems fine, It loads fine on other OS but only iOS and Mac have issues.

I see you have WP Rocket installed, have you followed https://docs.wp-rocket.me/article/18-using-wp-rocket-with-cloudflare?

I have enabled Cloudflare Proxy, please check…

It again stopped the loading on iOS devices and on safari browser in Mac.

Enabled that too, that’s very much basics with WP Rocket and Cloudflare integration so did that already. But enabled now after enabling Proxy and also verified the values like Zone ID and API.

sorry I can’t spend much more time on this issue. I see the following error in the logs:

Connection state changed (MAX_CONCURRENT_STREAMS == 256)!
* http2 error: Invalid HTTP header field was received: frame type: 1, stream: 1, name: [upgrade], value: [http:/1.1]
* HTTP/2 stream 0 was not closed cleanly: Unknown error code (err 1)
* stopped the pause stream!

Try disabling HTTP2 on your zone and check again in Safari:
CF dashboard -> Network -> disable HTTP/2

We can’t disable HTTP/2 from a users end…

the other solution is to serve responses from your origin using HTTP/2 and not HTTP/1.1.

Thank you, will try that.

If you’re on a paid plan, you can disable HTTP/2 with the API.

What’s the point to disable if we can’t have the benefit by using it.