Cloudflare interfering with email digest

I find that the only way to get my email digest feature on my wordpress site to generate emails is if I have development mode turned on. I have created a page rule to bypass caching, disable apps, and disable performance for my entire site, but it seems it’s still caching a small amount of data. I would think it was something else, but by turning on development mode my site is then able to generate the email digest. What should I try?

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails while using Coudflare for your domain name.

Can you share your domain name?
Is A mail hostname unproxied and set to :grey: (DNS-only)?
Is your WordPress plugin configured to use A mail hostname for sending e-mails?
is your MX record pointed to unproxied :grey: (DNS-only) A mail hostname?

Kindly, I’d suggest you to download and install below plugin as far as it works perfectly for WordPress, just configure it to use your Google Workspace e-mail with the credentials:

Tick the checkboxes the “Force name” and “Force email” → How to Set Up the Other SMTP Mailer in WP Mail SMTP .

Kindly, see below suggestions and tips for troubleshooting.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Furthermore, if you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT/CNAME records (for SPF, DKIM, DMARC if so?)
  3. You are using a hostname like yourdomain.com which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like mail.yourdomain.com (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

1 Like

My domain is packagedfoodreviews . com (it wouldn’t let me include a link in this message) My mx records as well as all records are DNS only. Only my domain is proxied through Cloudflare. I’m using WP Main SMTP premium version to send email through AWS SES. I have my email configured for SPF, DKIM, and DMARC. I’m using AWS Route 53 for my DNS records configuring. It does show up in Cloudflare and I have my site proxied through Cloudflare. My email functionality works fine in general. The only part I have noticed that doesn’t is the email digests for post and comment updates that’s sent out daily. The thing is, it doesn’t seem to even be generating the emails in the first place to send out. I’m using a Premium plugin called Peepso for my user interaction and email digest feature. It all worked fine before Cloudflare, but I like the protection offered here. As I mentioned if I turn on development mode here on Cloudflare, it works as intended, generates the emails and sends them out. So I’m not entirely sure how, but it seems that a service on my site isn’t working because of a caching issue. I set my whole domain to bypass cache, disable apps, and disable perfomance and it still doesn’t work unless I turn on development mode. Maybe there’s a rule for me to set up? I really don’t know for sure, but I’ve been building this site for about 3 years and I’m ready to go live and visible to search engines, but only when I get my email digest working again. Any help is much appreciated. Thanks.

Thank you for feedback. Interesting :thinking:

I haven’t used it and not familiar with it.
I wonder how the web app or the plugin fetches the content and sending them out.

Are there any challenged or blocked firewall events from your origin host/web server IP shown under the Security tab → WAF? :thinking:
Can you test this somehow manually and check if any event from your IP appears, if so?
Otherwise, if it’s using some external way, maybe that other IP is being catched and blocked.

Try by adding the origin host/web server IP to the Security tab menu → WAF tab → Tools → IP Access Rules with the action “allow”, that way it’s bypassed and WordPress website should work normally as expected while being proxied :orange:.

The requests might be hitting the “Bot Fight Mode” or “Browser Integrity Check” feature, which you might have enabled at your Cloudflare dashboard for your domain name. You can try to disable it and see if anything different, if so.