CloudFlare HTTPS/SSL sends me to GoDaddy Coming Soon page instead of my website content

The SSL certificate is properly installed it seems, but instead of sending me to my website content, for some reason Cloudflare recently started sending me to GoDaddy’s default “Coming Soon” page.
If I disable HTTPS and change the website name and address to accommodate that, then I can see my web content again.
What am I missing in SSL configuration?

If it’s specific to SSL, make sure your SSL is set Full Strict.

Check your DNS configuration, purge the cache if that page is cached in case.

1 Like

You will also want to make sure that your site loads over HTTPS when Cloudflare is paused.


When Cloudflare is paused HTTPS still does not work. I have to disable HTTPS for it to show my website content. Do I need to have an SSL certificate set up on the server as well as on Cloudflare?

Yes. You need a certificate on your server to secure the traffic between it and the Cloudflare proxy. If you don’t have access to free certificates from an automated certificate authority like Let’s Encrypt, you can always purchase a commercial certificate or use a free certificate from the Cloudflare Origin CA. Cloudflare Origin CA certificates will present a trust warning when accessed directly, so you will only want to use one on a site that you will proxy through Cloudflare.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.