Cloudflare gives virus message when using addthis


#1

I tried to use addthis to share this page https://newyorkseriousinjuryattorneys.com/faq on Facebook and addthis shows the following for the page content:

Attention Required! | Cloudflare
if you are on a personal connection, like at home, you can run an antivirus scan on your device to make sure it is not infected with malware.

I uploaded a screenshot.


#2

I didn’t see the screenshot so I will try to upload

it again here


#4

The site appears to be fine. I block foreign countries. What country are you in?

Phil


#5

No Malware Found
https://sitecheck.sucuri.net/results/newyorkseriousinjuryattorneys.com


#7

I’ve seen this here before. IIRC it was caused by a JS or captcha challenge. I can’t finde the thread right now. :frowning:


#8

AddThis support wrote:

Thank you for contacting AddThis support.

When I checked your page in Facebook debugger it’s reporting – Bad Response Code: URL returned a bad HTTP response code – https://www.screencast.com/t/pcvotnA7O

https://developers.facebook.com/tools/debug/og/object?q=https://newyorkseriousinjuryattorneys.com/faq

It seems like an issue with Facebook trying to scrape your site and Cloudflare is flagging it. You could try reaching out to Cloudflare to see what they have running that’s blocking Facebook.

I found this page too – this might help:


Regards,
Ribin!


#9

I tried changing the security level to Essentially off but that the not work. I also tried changing to development mode but that did not do anything. This was not a problem previously, although I’m not sure when this started happening.


#10

Is there a way to get help from Cloudflare? if I can’t get this fixed, I will have to give up AddThis or Cloudflare. AddThis has been very effective for me so I rather reluctant to give it up.


#11

DevMode is more about bypassing caching and performance. It’s probably some security feature that’s interfering.

I suggest you add a Page Rule:
Match: example.com/*
Settings: (Now this is where I suggest you pile on all the settings and set them all to disable/off/bypass)

Hopefully it’ll clear up. Then turn them back on one at a time to see which one is causing the problem.

If not…Plan B would be to go to Overview and use Advanced to “Pause Website.” This will completely bypass Cloudflare. At least that way you’ll know for sure if it’s Cloudflare or not.


#12

I tried clicking on Pause Website since that is a lot easier. When I did that, the problem cleared up. I then re-enabled Cloudflare and I did not encounter the problem again. I did the same thing on another subsite with the same results. I will try to share on Facebook again on those websites tomorrow on another computer and see what happens.


#13

Now you have some confirmation it’s a Cloudflare setting that’s causing this. The Page Rule method I posted above, though tedious, will hopefully help you track down which setting is causing this.


#14

I don’t know what to enter for a page rule


#15

I just posted on Facebook and it’s happening again. I don’t know what the problem is with Cloudflare.